0

I got recently a belt that repeats the input characters. It looks like this:

enter image description here

I don't know where it comes from nor how to turn it off. And best uninstall it altogether.

Not only does it annoy me all the time, but also is dangerous as it repeats the password after login (at least after suspend wake up).

What is it and how to get rid of it?

Ubuntu 16.04, LXDE.

  • 1
    run xprop, then click inside that belt. it will show what is that. – Ipor Sircer Nov 17 '16 at 18:13
  • Perfect. It's vokoscreen. Alles klar. Thanks. – Tomasz Nov 17 '16 at 18:15
2

Solved. Credits to Ipor Sircer.

run xprop, then click inside that belt. it will show what is that.

$ xprop
_NET_WM_SYNC_REQUEST_COUNTER(CARDINAL) = 50331999
_NET_WM_USER_TIME(CARDINAL) = 97031474
_NET_WM_STATE(ATOM) = _NET_WM_STATE_ABOVE, _NET_WM_STATE_STAYS_ON_TOP
WM_TRANSIENT_FOR(WINDOW): window id # 0x3000005
_NET_WM_WINDOW_OPACITY(CARDINAL) = 2998055602
XdndAware(ATOM) = BITMAP
_MOTIF_DRAG_RECEIVER_INFO(_MOTIF_DRAG_RECEIVER_INFO) = 0x6c, 0x0, 0x5, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x10, 0x0, 0x0, 0x0
WM_CLIENT_LEADER(WINDOW): window id # 0x3000005
_NET_WM_PID(CARDINAL) = 18303
_NET_WM_WINDOW_TYPE(ATOM) = _NET_WM_WINDOW_TYPE_TOOLTIP, _KDE_NET_WM_WINDOW_TYPE_OVERRIDE, _NET_WM_WINDOW_TYPE_NORMAL
_MOTIF_WM_HINTS(_MOTIF_WM_HINTS) = 0x2, 0x1, 0x0, 0x0, 0x0
WM_PROTOCOLS(ATOM): protocols  WM_DELETE_WINDOW, WM_TAKE_FOCUS, _NET_WM_PING, _NET_WM_SYNC_REQUEST
WM_NAME(STRING) = "vokoscreen"
WM_LOCALE_NAME(STRING) = "en_US.UTF-8"
WM_CLASS(STRING) = "vokoscreen", "Vokoscreen"
WM_HINTS(WM_HINTS):
        Client accepts input or input focus: True
        Initial state is Normal State.
        window id # of group leader: 0x3000005
WM_NORMAL_HINTS(WM_SIZE_HINTS):
        user specified location: 0, 756
        program specified location: 0, 756
        user specified size: 3200 by 120
        program specified size: 3200 by 120
        window gravity: NorthWest
WM_CLIENT_MACHINE(STRING) = "tomas-Latitude-E4200"
WM_COMMAND(STRING) = { "vokoscreen" }

The answer lies here:

WM_COMMAND(STRING) = { "vokoscreen" }

The recently installed Vokoscreen. Now I disable the 'Showkey' option, and it's back to normal.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.