3

I'm running Fedora 23 with Apache 2.4 and PHP 5.6.27. Both Apache and PHP are installed from the standard Fedora repo.

My problem is that despite setting Require all granted in my site's virtual host configuration I still get the following error when attempting to browse my web site (and a 403 Forbidden in my browser):

AH01630: client denied by server configuration: /home/kevin/appsdev/mywebapp/phpinfo.php

This is my virtual host configuration:

<VirtualHost 172.16.3.52:80>
    ServerName localdev.mywebapp.net
    DocumentRoot /home/kevin/appsdev/mywebapp

    <Directory /home/kevin/appsdev/mywebapp>
        AllowOverride All
        Require all granted
    </Directory>
</VirtualHost>

The above configuration is tacked onto the end of the out-of-the-box httpd.conf config file that shipped with Apache.

Apache is running as the apache user.

I've also set the ownership for /home/kevin/appsdev/mywebapp to:

chown -R apache:apache /home/kevin/appsdev/mywebapp

and my permissions as:

chmod -R 755 /home/kevin/appsdev/mywebapp

I even tried (rather naughtily) changing:

<Directory />
    AllowOverride none
    Require all granted   ## default is: Require all denied
</Directory>

I also disabled selinux.

There are no .htaccess files in the web site.

I've restarted apache but I still get the AH01630: client denied by server configuration.. error and a 403 Forbidden in my browser.

Running httpd -t tells me Syntax OK, so nothing bad there.

What am I doing wrong, I'm a bit stumped?

  • What are the permissions of phpinfo.php? – DopeGhoti Nov 17 '16 at 21:38
1

The user who runs webserver (apache by default) has to be able to open the file. That means that all the path have to be accessible for it. I saw, that you are using your home dir /home/kevin. These dirs have right set up for user and user's group only (like 0750), so apache is not able to go there.

You can allow to access files and directories inside with chmod o+x /home/kevin, but than anyone can read your home dir (if he or she knows the correct path). Better solution is to not use home dir and put files to /var/www/ or /srv/ and have correct rights for apache and your user too.

Anyway, always attach corresponding part of error log to your question. There should be more info about the problem.

  • Oddly, with a reboot, the issue magically went away. I did include the corresponding part of the error log in the question "AH01630: client denied by server...". The error wasn't caused by the apache user being unable to access the files and folders due to unix permissions, that would have generated this error: "AH00035: access to /phpinfo.php denied (filesystem path '/home/kevin/appsdev') because search permissions are missing on a component of the path" which I had already resolved. – Kev Nov 20 '16 at 18:09
  • This is my local development machine and, provided I'd set my unix permissions correctly, I've never had issues before running my dev bits and pieces from my home folder. The only difference in this case is that I'd switched from an older dev env running Apache 2.2 to Apache 2.4. – Kev Nov 20 '16 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.