2

I've tried by using the keyboard applications and shortcuts submenu by adding a command "matlab" and associating my desired key combination. This is based on the fact that if I run $ matlab from terminal it will open matlab as I have made the proper symbolic link in my /usr/local/bin folder.

However, when I try to use the keybind, it appears to work (matlab's loading window appears (the colorful one that is initializing matlab), but then disappears shortly after, and matlab never ends up opening.

I'm a fairly new linux user so I am sort of unsure why this wouldn't work. For example, I got the application name for the default xfce terminal (xfce4-terminal) and made a shortcut for that and it worked, but this didn't. If it matters, my distribution is debian.

  • Try using matlab -desktop in the shortcut. – Paul H. Nov 16 '16 at 19:29
  • where is the binary from matlab? You have made a Variable for it? did I understand it right? echo $matlab – user192526 Nov 16 '16 at 21:59
  • Paul, matlab -desktop worked. Thanks! I feel like it wasn't keeping that terminal operation going or something along those lines which is why it would display it and then disappear. – Aaron A. Nov 16 '16 at 22:13
0

Stolen from the comments:

Try using matlab -desktop in the shortcut

0

Since (at least) Matlab 2017a, the desktop file is created automatically in usr/share/applications/ (provided you install Matlab with sudo).

The default .desktop file containes:

[Desktop Entry]
Version=1.0
Type=Application
Terminal=false
Exec=matlab -desktop
Name=MATLAB
Icon=/usr/share/icons/hicolor/48x48/apps/matlab.png
Categories=Development;Math;Science
Comment=Scientific computing environment
StartupNotify=true
StartupWMClass=com-mathworks-util-PostVMInit

As you can see, the field Exec contains matlab -desktop, as suggested in the comments.

(Notice that the icon also comes by default)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.