1

I'm running Linux Mint 18 Cinnamon on my Asus X555LA, which also has Windows 10 installed on another partition (the backlight works perfectly in Windows).

However in Linux Mint: there's already an issue with Fn+F5/F6 not changing the backlight intensity. The various fixes I've tried (but haven't worked) include:

  • adding a 20-intel.conf file into the /usr/share/X11 folder.
  • added acpi_osi= to the /etc/default/grub
  • Running acpi_listen and pressing Fn+F5/F6 shows no output.
  • Installing xbacklight and running xbacklight -set $percentage

Until about two days ago I could skirt this issue by using the brightness slider in the UI, however even this no longer works and the screen brightness is stuck at 100%.

I am at a loss and no longer know what to do.

  • useful info would be dmeg output, dsdt dump, also what dirs exist in "/sys/class/backlight/" currently? – mikejonesey Nov 23 '16 at 18:47
0
lsmod | grep video

(video is the kernel driver that handles acpi calls for brightness)

You can check if "/sys/class/backlight/acpi_video0" exists, and you can use;

acpi_listen 

...to check for the acpi event.

Essentially the firmware triggers one of the Q functions which triggers a notify to the monitor with either 0x87 or 0x86, when this is received the brightness can be changed.

If for whatever reason the DSDT tables doesn't have certain methods like _DOD then kernel acpi wont recognize the definition of a monitor.

Regardless, you can boot your kernel with acpi_backlight=video to force video.ko to control the backlight (this will use acpi based values defined in BCL).

When you use vendor it'll use vendor specific acpi or rely simply on the pci device.

Regardless of acpi you can always change your brightness via pci bypassing acpi.

To do this check out /sys/class/backlight/ for a dir with the name amd or intel.

You can echo to the brightness file, this won't use the brightness levels defined in the DSDT tables so you actually get a larger variety of brightness levels.

PS... the only forced detections for Asus laptops are to force vendor.

These laptops are;

  • Asus UL30VT
  • Asus UL30A

There is no reference for "X555LA", so I'd try acpi_backlight=video before acpi_backlight=vendor.

  • 1
    No offence, but this answer just reads like a ramble. Any chance of clarifying what you mean, please? – Virtual Anomaly Nov 23 '16 at 14:49
  • If you try adding "acpi_backlight=video", in grub or whatever boot loader you have, then test the buttons and also acpi_listen again. if this does not solve your problem, i'll update the post. – mikejonesey Nov 23 '16 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.