0

I've tried a few console applications like vim, mg, emacs, nano, and joe as a git editor, and none of them seem to have any problems with being invoked "indirectly" like this (I don't know the actual term for starting an editor as a subprocess and then giving it control). jed, uniquely among editors I have tried, hangs forever with the message loading /usr/local/Cellar/jed/0.99-19/jed/lib/emacs.sl when it is launched indirectly via git commit or ack <search term> --pager='jed'. I've checked the file and it's there, it was installed as part of the jed formula on Homebrew on OS X.

I've tried running git commit and ack ... --pager='jed' and such under bash and zsh and both exhibit the same behavior.

I'm trying to get an understanding of the problem so I can configure my terminal/shell differently or, failing that, file a bug report. When an editor is launched from another program and takes control of the terminal, what exactly is happening? Since one of several pieces of software could be responsible for this strange behavior, how would I go about determining which component is behaving in a nonstandard way?

  • The obvious thing to check for (by reading its source-code) is whether jed checks if its standard input/output are a terminal, rather than a pipe (as suggested by --pager). – Thomas Dickey Nov 15 '16 at 22:49
  • This bug has been fixed in the latest development snapshot of jed. jedsoft.org/snapshots/#jed I'll update the homebrew formula after the next release. – Gregory Nisbet Nov 18 '16 at 19:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.