1

My internet connection doesn't work on Debian after a fresh install.
This is what I encountered after a couple of hours searching:

My ifconfig has an eth0 entry.
cat interfaces returns

source /etc/network/interfaces.d/*

# The loopback network interfcae
auto lo
iface io inet loopback

auto eth0
iface eth0 inet dhcp

(I added auto eth0 and iface eth0 inet dhcp manually)

My routing table ('route' and 'route -n') are empty (also after /etc/init.d/networking restart)

ping 8.8.8.8 returns Network is unreachable

and route add default gw 192.168.1.1 returns :

SIOCADDRT: Network is unreachable 

I googled a lot and I couldn't find and answer.
This is after a fresh install, during the install the networking part failed as well and I figured to not configure it yet and do it manually after the install.
After the install I installed the firmware: firmware-realtek_0.43_all.deb file (downloaded from here ) with dpkg -i firmware-realtek_0.43_all.deb

closed as off-topic by telcoM, sebasth, user88036, Kiwy, Thomas Oct 8 '18 at 12:58

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – telcoM, sebasth, Community, Kiwy, Thomas
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Bring eth0 up: ifup eth0 – Ipor Sircer Nov 15 '16 at 17:53
  • I guess it's possible that the lack of non-free firmware in Debian is significant here, but have you confirmed that? For example, does your ethernet connection already work fine with a different distro which packages those drivers by default? – SauceCode Nov 15 '16 at 18:01
  • What is the output of ip link and ip addr? – aventurin Nov 15 '16 at 18:47
  • @IporSircer The output is 'interface eth0 already configured' – Rens Oliemans Nov 15 '16 at 20:24
  • 1
    @SauceCode Sorry for the late reply, but yes. This was indeed ouside of the scope of the comments, however I 'fixed' the problem. I re-registered my machines at my campus' administration system and waited a day, and it worked again. So, it's fixed, but thanks for the replies! – Rens Oliemans Nov 25 '16 at 0:18
1

So the problem is fixed now.
I didn't do too much myself, however the problem was that with my ethernet connection, I didn't have any internet connection on any Unix OS (granted, I only tested Debian and Ubuntu (although on two separate machines)), however it did work on Windows 10.

I didn't understand this and simply re-registered my devices at my campus' administration system, waited a day, and now it works. Thanks for the replies!

0

Modify your /etc/resolv.conf file with:

domain <provider-address.com>
search <provider-address.com>
nameserver <first-provider-ip>
nameserver <second-provider-ip>
  • At least for testing, you can use one of Google's public DNS servers, so you could add nameserver 4.2.2.2 – James T Snell Nov 15 '16 at 19:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.