10

I am being troubled by the infamous shutdown hang/freeze error. Whenever I shutdown mint, only the first dot on the splash screen turns green and then it kind of freezes. I also had this prob on Ubuntu 16.04.I intend to use linux for gaming. Here are my system specs-

           Desktop: Cinnamon 3.0.7 (Gtk 3.18.9-1ubuntu3.1)
           Distro: Linux Mint 18 Sarah
Machine:   Mobo: Intel model: DG33FB v: AAD81072-307
           Bios: Intel v: DPP3510J.86A.0407.2008.0218.0923 date: 02/18/2008
CPU:       Quad core Intel Core2 Quad Q6600 (-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 ssse3 vmx) bmips: 19199
           clock speeds: max: 2394 MHz 1: 1596 MHz 2: 1596 MHz 3: 2128 MHz
           4: 1862 MHz
Graphics:  Card: NVIDIA GT218 [GeForce 210] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1024x768@60.00hz
           GLX Renderer: Gallium 0.4 on NVA8
           GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card-1 NVIDIA High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel 82801I (ICH9 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic
Network:   Card: Intel 82566DC-2 Gigabit Network Connection
           driver: e1000e v: 3.2.6-k port: 30e0 bus-ID: 00:19.0
           IF: enp0s25 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 160.0GB (4.9% used)
           ID-1: /dev/sda model: Hitachi_HDS72101 size: 160.0GB
Partition: ID-1: / size: 17G used: 5.4G (35%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 2.13GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 47.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 178 Uptime: 6 min Memory: 646.8/1990.4MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.421) inxi: 2.2.35 

Turning off the network before shutting down makes no difference, so it isn't due to unreachable remote servers.

Reboot works fine.

Result of journalctl --boot -1 -e --full

Specifying boot ID has no effect, no persistent journal was found

Verbose booting had a fail line, which said something about not being able to load kernel modules.

Result of verbose shutdown(last two lines):

[OK] Reached target shutdown.
[54.278173] reboot: power down

Result of systemctl status

● lol-desktop
    State: degraded
     Jobs: 0 queued
   Failed: 1 units
    Since: Thu 2016-11-17 18:35:37 IST; 5min ago

P.S. I dual boot it with windows 7.

  • Run journalctl --boot -1 -e --full, edit your question, and put the relevant output there. This will show people what systemd thought that it was doing at the time. – JdeBP Nov 15 '16 at 12:43
  • Edits are done. – Shivodit Gill Nov 15 '16 at 15:16
  • Please guys, do reply, this issue is really frustrating – Shivodit Gill Nov 16 '16 at 12:18
  • The journal is what tells people what was going on. "It kind of freezes." does not. Unfortunately, you've configured your system to discard the journal at every shutdown, rather than store it persistently in /var/log/journal, so you cannot tell the world what the journal recorded, and people cannot then diagnose from that what was (or was most likely) going wrong. – JdeBP Nov 16 '16 at 19:52
  • So, how do i enable it? Do i need to do verbose shutdown? – Shivodit Gill Nov 17 '16 at 12:40
7

I fought two days with Linux Mint 18.3 system on a Dell 5577 laptop (Nvidia 1050). On shutdown or reboot the screen was black and nothing happened.

None of the following helped :(

  • modification of grub (adding GRUB_CMDLINE_LINUX="apm=power_off", "acpi=force", etc.)
  • disabling EuP (powering USB port on the switched off computer)

What helped :)

  • Select Menu -> Administration -> Driver management -> select nvidia driver instead of nouveau, wait patiently, because it lasts a little, first reboot or shutdown will fail, but after restart it finally works fine! :)

Search: Linux Mint does not shutdown or reboot, linux ubuntu does not shutdown or reboot, linux mint doesn't shut down or reboot, linux ubuntu doesn't shut down or reboot

| improve this answer | |
  • 1
    Exactly the same for me with Dell XPS 15. Unfortunately the Nvidia drivers are unusable as just watching a fullscreen video is enough for them to drive the fans so hard you can't actually hear anything. This occurs with Prime set to Nvidia or Intel graphics. – Neutrino Mar 4 '18 at 11:03
  • Legend, this worked for me on an HP Zbook Studio G3. – Sean Missingham May 26 '18 at 6:56
  • Worked for an Asus Zenbook Pro UX550. Thanks tons !! – ether_joe Dec 5 '18 at 5:50
  • Super slow reboots and shutdowns on my Lenovo T430 with Nvidia NVS 5400M solved by choosing Nvidia driver instead of nouveau. Thanks! – Jaxian May 3 '19 at 20:23
3

What worked for me in Gentoo linux (kernel 4.17.5) solving this problem was to add as an option for the nouveau driver de following:

vram_pushbuf=1

(nouveau.vram_pushbuf=1 when nouveau is inserted in the kernel).

I discovered this from an error message at the end of the halt process. The system hanged when trying to shut off the video as the final porcess for a complete shutdown without this option for my nvidia GPU.

| improve this answer | |
1

This problem was actual for me too. What is the most interesting - when I closed first manually user session and then shut the system down, everything went smoothly without any delay. Today I devoted some time to solve the issue and here are some results. The problem arises because the system waits at the shutdown for some thing which in its opinion must happen. The very thing is individual for each separate case. In my case it was even two problems one of which I've found. The system was looking for a hard drive which didn't exist. How so? Because I've experimented with some other versions of Linux and chose for all versions the same drive device as swap. During installation of the second Linux, UUID of the device was changed but in system files of the first Linux it remained unchanged. But, once again, - it was my problem, yours may be not alike at all. After I fixed the above problem, I still had another one. I lost my hope and just gave up to the temptation to solve the problem with a brute force. I changed in the /etc/systemd/user.conf and /etc/systemd/system.conf files parameter DefaultTimeoutStopSec from 90 seconds to 5 seconds. Don't forget to uncomment the line (to remove # sign in the beginning of the line with the parameter DefaultTimeoutStopSec).

Now it works fine, system shuts down very fast.

| improve this answer | |
1

Another possible solution - especially for newer hardware using (U)EFI - is to add the boot parameter apm=power_off. You can add it to the definition of GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub or add the line if it does not exist yet.

GRUB_CMDLINE_LINUX_DEFAULT="apm=power_off"

Then update the grub installation according to your operating systems manual, e.g:

update-grub # Debian/Ubuntu
grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg # EFI on Fedora etc
grub2-mkconfig -o /boot/grub2/grub.cfg # BIOS
| improve this answer | |
0

i assume your system powers off after the 54s? its possibly a hung process, if you have a lot of disk activity on shutdown check /var/lib/systemd/coredump/ for files, you could then turn off core dumps (as a work around rather than root solution)

| improve this answer | |
0

Turning Off USB 3.0 legacy mode or usb3.0 configuration in pre-os in BIOS, worked for me.

| improve this answer | |
0

Linux Mint 18.1:

My problem was that my new PC hanged at unsystematic moments at shutdown/power off. I had to push the on/off button for several seconds (also mechanical power off).

After I changed a setting in the UEFI/BIOS the problem was gone:

  1. Open the UEFI/BIOS:

  2. Advanced → Powermanagement → EuP-setting disabled

  3. Exit by saving the settings

Then restart your computer and everything should be OK.

| improve this answer | |
  • 1
    What's the EuP setting do, or stand for? – Xen2050 Jan 20 '19 at 3:41
0

For me this problem was fixed after I deleted the "quiet" and "splash" values from the GRUB_CMDLINE_LINUX_DEFAULT parameter in grub.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.