1

I am trying to use Mutt to send an encrypted message. When I tell it to send, I am prompted "enter keyID for curly@there.com". I hit enter and get a menu:

1 ?  2048/0x7F2D434B9741E8AC RSA  es
2 +  2048/0x5D7BF71DA8215631 RSA  es
3 +  2048/0x5D7BF71DA8215631 RSA  es Me <me@place.com>
4 ?  2048/0x8F2D434B9241E8AC RSA  es Moe <Moe@place.com>

Meanwhile if I use gpg -k I get

/home/Me/.gnupg/pubring.kbx
---------------------------
pub   rsa4096 2014-12-15 [C]
      EF6E286DDA75EA2A4BA7AE684E2C6E8713298290
uid           [ unknown] Larry (signing key) <larry@place.com>
sub   rsa4096 2014-12-15 [S]
sub   rsa4096 2014-12-15 [S]
sub   rsa4096 2014-12-15 [S]

pub   rsa2048 2016-06-06 [SC] [expires: 2017-03-02]
   A7EF81E08C076AA79B15041A5D7BBF71BD821562
uid           [ultimate] Me <me@place.com>
sub   rsa2048 2016-06-06 [E] [expires: 2017-03-02]

pub   rsa2048 2011-04-10 [SC]
      4AA4757CCC9C4B1D18AB28B77F2D432B9741E8AC
uid           [ unknown] Moe <moe@place.com>
sub   rsa2048 2011-04-10 [E]

pub   rsa4096 2014-09-06 [SC] [expires: 2019-08-05]
      8B641D862187FDE1E215C6B7CF62CAE28A17E01D
uid           [ unknown] Curly <curly@here.com>
uid           [ unknown] Curly <curly@there.com>

Any idea why Mutt is not finding all of my public keys? For what it's worth, it is missing exactly the 4096-bit ones. Nope, I addded a 4096-bit key that worked fine.

Finally, here is the output of mutt -v:

Mutt 1.7.1 (2016-10-04)
Copyright (C) 1996-2016 Michael R. Elkins and others.
Mutt comes with ABSOLUTELY NO WARRANTY; for details type `mutt -vv'.
Mutt is free software, and you are welcome to redistribute it
under certain conditions; type `mutt -vv' for details.

System: Linux 4.8.7-1-ARCH (x86_64)
ncurses: ncurses 6.0.20150808 (compiled with 6.0)
libidn: 1.33 (compiled with 1.33)
hcache backend: GDBM version 1.12. 16/05/2016 (built May 31 2016     18:36:34)

Compiler:
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.1/lto-    wrapper
Target: x86_64-pc-linux-gnu
Configured with: /build/gcc/src/gcc/configure --prefix=/usr --    libdir=/usr/lib --libexecdir=/usr/lib --mandir=/usr/share/man -    -infodir=/usr/share/info --with-bugurl=https://bugs.archlinux.org/ --enable-languages=c,c++,ada,fortran,go,lto,objc,obj-c++ --enable-shared --enable-threads=posix --enable-libmpx --with-system-zlib --with-isl --enable-__cxa_atexit --disable-libunwind-exceptions --enable-clocale=gnu --disable-libstdcxx-pch --disable-libssp --enable-gnu-unique-object --enable-linker-build-id --enable-lto --enable-plugin --enable-install-libiberty --with-linker-hash-style=gnu --enable-gnu-indirect-function --disable-multilib --disable-werror --enable-checking=release
Thread model: posix
gcc version 6.2.1 20160830 (GCC) 

Configure options: '--prefix=/usr' '--sysconfdir=/etc' '--enable-gpgme' '--enable-pop' '--enable-imap' '--enable-smtp' '--enable-hcache' '--enable-sidebar' '--with-curses=/usr' '--with-regex' '--with-gss=/usr' '--with-ssl=/usr' '--with-sasl' '--with-idn' 'CFLAGS=-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong' 'LDFLAGS=-Wl,-O1,--sort-common,--as-needed,-z,relro' 'CPPFLAGS=-D_FORTIFY_SOURCE=2'

Compilation CFLAGS: -Wall -pedantic -Wno-long-long -march=x86-64 -    mtune=generic -O2 -pipe -fstack-protector-strong

Compile options:
-DOMAIN
-DEBUG
-HOMESPOOL  -USE_SETGID  +USE_DOTLOCK  -DL_STANDALONE  +USE_FCNTL  -USE_FLOCK   
+USE_POP  +USE_IMAP  +USE_SMTP  
+USE_SSL_OPENSSL  -USE_SSL_GNUTLS  +USE_SASL  +USE_GSS      +HAVE_GETADDRINFO  
-HAVE_REGCOMP  +USE_GNU_REGEX  
+HAVE_COLOR  +HAVE_START_COLOR  +HAVE_TYPEAHEAD  +HAVE_BKGDSET  
+HAVE_CURS_SET  +HAVE_META  +HAVE_RESIZETERM  
+CRYPT_BACKEND_CLASSIC_PGP  +CRYPT_BACKEND_CLASSIC_SMIME      +CRYPT_BACKEND_GPGME  
-EXACT_ADDRESS  -SUN_ATTACHMENT  
+ENABLE_NLS  -LOCALES_HACK  +HAVE_WC_FUNCS  +HAVE_LANGINFO_CODESET      +HAVE_LANGINFO_YESEXPR  
+HAVE_ICONV  -ICONV_NONTRANS  +HAVE_LIBIDN  +HAVE_GETSID      +USE_HCACHE  +USE_SIDEBAR  
-ISPELL
SENDMAIL="/usr/sbin/sendmail"
MAILPATH="/var/mail"
PKGDATADIR="/usr/share/mutt"
SYSCONFDIR="/etc"
EXECSHELL="/bin/sh"
-MIXMASTER
To contact the developers, please mail to <mutt-dev@mutt.org>.
To report a bug, please visit http://bugs.mutt.org/.
0
1

The keys that Mutt lists are the encryption keys. In this example I do not have a key for Curly that is usable for encryption (such a key would be marked with the "[E]" tag).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.