I tried to swap out a btrfs with a lager disk. The idea was to add the new disk and remove the old one. So I added to the original 4TB disk with about 3TB data a new 5TB disk and started the btrfs remove of the old disk. I ended with

btrfs ERROR: error removing device: No space left on device

So I tried to re balance made more space. Including with the dusage parameter like here. I even tried removing the new device. I always get No space left. The array is not even close to full, there is enough space on ether disk left for all data. I also tried multiple kernels including 4.8 and 4.4.

btrfs fi sh /mnt/backup/
Label: 'Backup'  uuid: 045f75c3-fe26-436d-b2ff-c84b70c60eeb
Total devices 2 FS bytes used 2.56TiB
devid    1 size 3.64TiB used 2.58TiB path /dev/md127p1
devid    2 size 4.55TiB used 339.00GiB path /dev/sdd

btrfs fi df /mnt/backup/
Data, RAID0: total=678.00GiB, used=677.91GiB
Data, single: total=2.25TiB, used=1.89TiB
System, single: total=32.00MiB, used=316.00KiB
Metadata, single: total=4.00GiB, used=3.19GiB
GlobalReserve, single: total=512.00MiB, used=0.00B

Is there something left I can try?

  • (random guess) I wonder if it's the RAID0 (instead of "single") data? Would be hard to RAID0 on a single drive... – derobert Nov 14 '16 at 23:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.