1

There are many threads about the topic 2014 but their proposal does not work in R 3.3.1, apparently because the dependencies are not met but I could not install them neither

install.packages("Vennerable", repos="http://R-Forge.R-project.org")

Output as root

> install.packages("Vennerable", repos="http://R-Forge.R-project.org")
Installing package into ‘/usr/local/lib/R/site-library’
(as ‘lib’ is unspecified)
Warning: dependencies ‘graph’, ‘RBGL’ are not available
trying URL 'http://R-Forge.R-project.org/src/contrib/Vennerable_3.0.tar.gz'
Content type 'application/x-gzip' length 1727552 bytes (1.6 MB)
==================================================
downloaded 1.6 MB

ERROR: dependencies ‘graph’, ‘RBGL’ are not available for package ‘Vennerable’
* removing ‘/usr/local/lib/R/site-library/Vennerable’

The downloaded source packages are in
    ‘/tmp/Rtmp9Ubsk3/downloaded_packages’
Warning message:
In install.packages("Vennerable", repos = "http://R-Forge.R-project.org") :
  installation of package ‘Vennerable’ had non-zero exit status

> install.packages("graph")
Installing package into ‘/usr/local/lib/R/site-library’
(as ‘lib’ is unspecified)
Warning message:
package ‘graph’ is not available (for R version 3.3.1) 

> install.packages("RBGL")
Installing package into ‘/usr/local/lib/R/site-library’
(as ‘lib’ is unspecified)
Warning message:
package ‘RBGL’ is not available (for R version 3.3.1) 

R: 3.3.1
OS: Debian 8.5
Package documentation: here

1

The packages graph and RBGL are in the Bioconductor package repository, the following works for me:

R> source("http://bioconductor.org/biocLite.R"); biocLite(c("graph", "RBGL"))
R> install.packages("reshape")
R> install.packages("Vennerable", repos="http://R-Forge.R-project.org")
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.