0

I'm using Solus version for linux (on Lenovo ThinkPad T61 if that is important), and when i tried to download aircrack-ng with the following commands, they returned error, saying that:

System error. Program terminated.
Repo item aircrack-ng not found

That happend after i tried to install this package using the "Package Installer" on my Solus, with this command:

1. sudo eopkg install aircrack-ng

I've tried to install this package manually, by downloading the tar.gz file, and extract his content to another folder, then, to open the folder, and type this command:

2. sudo eopkg it -c system.devel

But this time, it just tells me that there are no packages to install.

Also the 3. make command, wasn't working, because I didn't found any Makefile inside the package itself.

I don't realy understand why it didnt found this package, when Solus using Linux as good as other systems does. so if you can help, Thank you

  • What are the "few commands" you used to try to download aircrack-ng? – Wildcard Nov 13 '16 at 9:41
  • @Wildcard I changed it. but it was the sudo eopkg commands, i searched for some alternatives for them, but i couldn't find any. – Argaman Nov 13 '16 at 9:52
0

In your first try, eopkg package manager apparently hasn't found aircrack-ng in its repositories.
After a look at Package Management page in Solus Project wiki I found a link to a package list on this section, then I downloaded that link and I didn't found aircrack-ng.

Let's do the compilation ...


BEFORE STARTING:
Maybe you need to resolve some dependencies in order to make the installation of aircrack-ng in Solus (for more details read INSTALLING file in aircrack-ng package):

I think these mandatory and optional dependencies are already present in your system as you may find in this page of Solus git repo.

Mandatory deps:

  • libgcrypt user@host:~$ sudo eopkg install libgcrypt
  • ethtool user@host:~$ sudo eopkg install ethtool
  • libnl user@host:~$ sudo eopkg install libnl
  • pkg-config user@host:~$ sudo eopkg install pkg-config

Optional deps:

  • libpcre user@host:~$ sudo eopkg install libpcre
  • sqlite3 user@host:~$ sudo eopkg install sqlite3


Compiling and Installing ...

1. Get the source code download from aircrack-ng official page:
user@host:~$ wget http://download.aircrack-ng.org/aircrack-ng-1.2-rc4.tar.gz

2. Extract the content and enter in the directory:
user@host:~$ tar -xzf aircrack-ng-1.2-rc4.tar.gz
user@host:~$ cd aircrack-ng-1.2-rc4

3. Now you simply type:
user@host:~$ make
user@host:~$ make strip
user@host:~$ sudo make install

If a problem arrives, first look at https://trac.aircrack-ng.org/ticket/1671, or try to send an email to a developer.

  • 1
    Wow man, huge thanks ! You realy saved me from switch to anouther linux 😅 – Argaman Nov 14 '16 at 5:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.