0

The provided sendmail.mc file is used to enable ports 587/submission and/or 465/smtps. The problem is that enabling either one disables port 25/smtp.

I only have one server and would like to use it as MSA and MTA.

Traffic on 587 should be authenticated, on 25 should not.

TIA

See RFC 2476

  • The posted question is perfectly legitimate. There is a group of folks who are experts BUT when they find something they ignore, their reaction is to blame the victim and click the question down. StackExchange has found a mutually beneficial way to have these experts working for free. The payment is schadenfreude : they get to feel better by humiliating the users. – Travis Banger Nov 13 '16 at 15:44
  • 1
    1. SMTPS is deprecated. 2. SuperUser SE (or, possibly, ServerFault SE) is likely a better place to ask this kind of question. – countermode Nov 14 '16 at 8:35
1

Add the following lines to your sendmail.mc and generate new sendmail.cf

dnl Disable default MSA port support
FEATURE(`no_default_msa')dnl
dnl Modifiers=E - disable ETRN support
dnl Modifiers=a - require SMTP authentication
dnl Modifiers=s - provide smtps
DAEMON_OPTIONS(`Family=inet6, Name=MTA-v6, Port=smtp)dnl
DAEMON_OPTIONS(`Family=inet,  Name=MTA-v4, Port=smtp)dnl
DAEMON_OPTIONS(`Family=inet6, Name=MSP-v6, Port=submission, Modifiers=Ea)dnl
DAEMON_OPTIONS(`Family=inet,  Name=MSP-v4, Port=submission, Modifiers=Ea)dnl
DAEMON_OPTIONS(`Family=inet6, Name=SMTPS-v6, Port=smtps, Modifiers=Eas)dnl
DAEMON_OPTIONS(`Family=inet,  Name=SMTPS-v4, Port=smtps, Modifiers=Eas)dnl

If smtp (25), submission (587) or smtps (465) are not defined in you /etc/services file then use port numbers instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.