I am renting a server, running Ubuntu 16.04 at a company, let's name it company.org.

Currently, my server is configured like this:

  • hostname: server737263
  • domain name: company.org

Here's my FQDN:

user@server737263:~ $ hostname --fqdn

This is not surprising.

I am also renting a domain name, let's name it domain.org. What I would like to do would be to rename my server as server1.domain.org.

This means configuring my hostname as server1 and my domain name as domain.org.

How can I do it correctly?

Indeed, the manpage for hostname is not clear. To me at least:




  • When called with one argument or with the --file option, the commands set the host name or the NIS/YP domain name. hostname uses the sethostname(2) function, while all of the three domainname, ypdomainname and nisdomainname use setdomainname(2). Note, that this is effective only until the next reboot. Edit /etc/hostname for permanent change.



  • You cannot change the FQDN with hostname or dnsdomainname.


So it seems that editing /etc/hostname is not enough? Because if it really changed the hostname, it would have changed the FQDN. There's also a trick I read to change the hostname with the command sysctl kernel.hostname=server1, but nothing says whether this is the correct way or an ugly trick.


  1. What is the correct way to set the hostname?

  2. What is the correct way to set the domain name?

6 Answers 6


Setting your hostname:

  • You'll want to edit /etc/hostname with your new hostname.

  • Then, run sudo hostname $(cat /etc/hostname).

Setting your domain, assuming you have a resolvconf binary:

  • In /etc/resolvconf/resolv.conf.d/head, you'll add then line domain your.domain.name (not your FQDN, just the domain name).

  • Then, run sudo resolvconf -u to update your /etc/resolv.conf (alternatively, just reproduce the previous change into your /etc/resolv.conf).

If you do not have resolvconf, just edit /etc/resolv.conf, adding the domain your.domain.name line.

Either way:

Finally, update your /etc/hosts file. There should be at least one line starting with one of your IP (loopback or not), your FQDN and your hostname. grepping out ipv6 addresses, your hosts file could look like this: localhost service.domain.com service

In response to hostnamectl suggestions piling up in comments: it is not mandatory, nor exhaustive.

It can be used as a replacement for step 1 & 2, IF you OS ships with systemd. Whereas the steps given above are valid regardless of systemd being present (pclinuxos, devuan, ...).

  • 8
    Both those conf files say DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN on my server (same version).
    – Walf
    Commented May 1, 2017 at 1:26
  • 11
    Don't be fooled by the fact that the "DO NOT EDIT" warning appears in /etc/resolvconf/resolv.conf.d/head. Everything in the head file is prepended to the resulting /etc/resolv.conf output file, so that's why the warning is in there, so that it shows up in the final result. Threw me for a loop at first.
    – njbair
    Commented Jan 6, 2018 at 23:24
  • 7
    This doesn't seem to apply to 18.04 LTS - there's no such file /etc/resolvconf/resolv.conf.d/head and there's no such utility resolvconf.
    – inopinatus
    Commented Jun 4, 2018 at 3:42
  • 4
    You could update the answer with hostnamectl
    – Déjà vu
    Commented Aug 25, 2018 at 5:10
  • 3
    Note also that if you use AWS you'll also need to preserve the hostname after reboots - sudo nano /etc/cloud/cloud.cfg update preserve_hostname: true (default is false).
    – B. Shea
    Commented Jun 24, 2019 at 23:55

sudo nano /etc/hostname


sudo nano /etc/hosts   hostname.domain.com hostname localhost


MUST HAVE SINGLE HOSTNAME after FQDN in /etc/hosts file. Works fine on Ubuntu 18.04.1 and all other versions. On EC2 and elsewhere.

Didn't mess with resolve file or anything else.

That shows hostname in shell and then has the FQDN when you need it.

  • best answer IMO Commented Nov 18, 2021 at 23:09
  • @MikeCiffone Technically, hostname should not contain the domain name -- i.e. should not be FQDN. Many deployments do it, but it should not be done that way. Note that in-kernel hostname under Linux after 1.0 is restricted to 64 characters (see man 2 sethostname) because that's the value of HOST_NAME_MAX. (Until 1.0 it was mere 8 bytes.) Commented Jan 5, 2022 at 14:52
  • @IvanVučica Oh that's interesting, I wasn't aware. Commented Jan 5, 2022 at 21:03
  • 1
    @bfontaine You don't have to care about any of the reasons I'll state -- most of my hosts were configured with hostname=fqdn most of the time, and they worked. One reason is that your FQDN, not shortname, is then limited to 63ch (HOST_NAME_MAX). Another is that molly-guard will require you to type fqdn, not the shortname. Another is that hostname CLI prints out the full FQDN, not just hostname -f. Another is that some software might print out FQDN in place of shortname, or append the domain a second time to the FQDN (i.e. foo.example.org.example.org instead of foo.example.org). Commented Mar 1, 2022 at 19:42
  • 2
    You can, of course, dismiss all of these as hypotheticals -- but I feel correctness of having the hostname contain just, well, the hostname is more correct and professional. Commented Mar 1, 2022 at 19:42

Instructions written against Ubuntu 18.04.3 LTS (bionic)

Change the hostname:

sudo hostnamectl set-hostname server1

Check result by running hostnamectl:

root@www:/# hostnamectl
   Static hostname: server1       <-- Check this value
         Icon name: computer-vm
           Chassis: vm
        Machine ID: 202c4264b06d49e48cfe72599781a798
           Boot ID: 43654fe8bdbf4387a0013ab30a155872
    Virtualization: xen
  Operating System: Ubuntu 18.04.3 LTS
            Kernel: Linux 4.15.0-65-generic
      Architecture: x86-64

Change the domain via new network manager, Netplan, by editing /etc/netplan/01-netcfg.yaml and changing the search parameter:

sudoedit /etc/netplan/01-netcfg.yaml

Sample configuration:

# This file describes the network interfaces available on your system
# For more information, see netplan(5).
  version: 2
  renderer: networkd
      dhcp4: yes
          search: [ domain.org ]

Test changes by logging in a second time, and running sudo netplan try in one of the sessions and checking settings in the other:

# netplan try
Do you want to keep these settings?

Press ENTER before the timeout to accept the new configuration

Changes will revert in  97 seconds
Configuration accepted.
# systemd-resolve --status
Link 2 (eth0)
      Current Scopes: DNS
       LLMNR setting: yes
MulticastDNS setting: no
      DNSSEC setting: no
    DNSSEC supported: no
         DNS Servers:
          DNS Domain: domain.org      <-- Check this value
# cat /etc/resolv.conf
options edns0
search domain.org    <-- Check this value
# hostname -f

It all is well, press ENTER at the sudo netplan try prompt to make things permanent.


~$ man hostname

       You cannot change the FQDN with hostname or dnsdomainname.

       The  recommended  method  of  setting the FQDN is to make the hostname be an alias for the fully qualified name using /etc/hosts,
       DNS, or NIS. For example, if the hostname was "ursula", one might have a line in /etc/hosts which reads

        ursula.example.com ursula

       Technically: The FQDN is the name getaddrinfo(3) returns for the host name returned by gethostname(2).  The DNS  domain  name  is
       the part after the first dot.

       Therefore  it  depends  on the configuration of the resolver (usually in /etc/host.conf) how you can change it. Usually the hosts
       file is parsed before DNS or NIS, so it is most common to change the FQDN in /etc/hosts.

       If a machine has multiple network interfaces/addresses or is used in a mobile environment,  then  it  may  either  have  multiple
       FQDNs/domain  names  or  none at all. Therefore avoid using hostname --fqdn, hostname --domain and dnsdomainname.  hostname --ip-
       address is subject to the same limitations so it should be avoided as well.


This was kindly pointed out by poige in another thread and is exactly what Lutz proposed here.

You should not put your fqdn into /etc/hostname.


I tried to change my domain entry from myhome.local to myhome.lan I had to edit the /etc/hosts file and the /etc/network/interfaces file. My /etc/hosts file now looks like:   localhost server.myhome.lan   server

and my /etc/network/interfaces file now looks like:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto enp2s0
iface enp2s0 inet static
    # dns-* options are implemented by the resolvconf package, if installed
    dns-search myhome.lan

It works fine for me.


none of this is a concrete solution, so i have started installing VPN in all of my devices. after installing VPN in all devices, it can recognise the devices very well.

i have started using netbird (free for upto 100 devices). following are opensource solutions you should consider

  • NetBird
  • Taailscale
  • ZeroTier

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .