2

I have fedora 24, a USB drive, windows 7 x64 iso file, and a valid product key. How can I create a bootable USB install media?

I have tried several things, none successful. I have followed this guide and no part of the process failed, threw errors, or acted unusual. This guide basically has you create an NTFS partition with parted, set the boot flag, and then write the iso with unetbootin 494, which is old but the last version that would write to an NTFS partition. When I try and boot from the drive I get "This is not a bootable disk. Please insert a bootable floppy and press any key to try again..."

If I boot fedora I can mount and read this drive correctly, it contains the files from a Windows install disk.

My laptop is about 5 years old with traditional boot process, none of the new EFI stuff.

1

Format your USB to ntfs , then install the ms-sys package from the direct link (sourceforge)

Install it:

tar xvf ms-sys-2.5.3.tar.gz
cd ms-sys-2.5.3
make
make install

as root run : ms-sys -7 /dev/sdx

  • 1
    The answer is confusing. Does it mean that I need to use the same device (say, /dev/sdb) in both commands? If this is the case, then it makes no sense because dd would overwrite everything done by ms-sys. I assume that the first command (ms-sys) should use the disk device (for example, /dev/sdb), whereas the second command should use the partition device (for example, /dev/sdb1). – pvgoran Aug 25 '18 at 17:05
1

The reason for this problem seems to be winusb creating NTFS filesystems without a proper boot loader code (or at least without a boot loader code that can boot Windows 7). It relies on mkfs.ntfs for filesystem creation, and the latter might use a working boot loader code before, but doesn't do this as of now (ntfs3g version 2017.3.23).

When I encountered this problem, the following worked for me:

  1. Ensure that the ms-sys program is installed (install it from your distribution's repository, or refer to @GAD3R's answer for installation from source).
  2. Run ms-sys --ntfs /dev/sdXN, where sdXN is the block device of the partition on the USB drive, for example, sdb1.

ms-sys's manual states that the --ntfs option "probably is of no practical use', but looks like it actually helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.