1

My debian 8 is broken. I this message

enter image description here

It seems that libopencc1 is broken and gnome-shell does not work anymore. I tried reinstalling, removing, purging it and it won't work. I also tried sudo apt-get -f install, sudo dpkg --reconfigure -a, sudo apt-get dist-upgrade and nothing fixes the issue. I tried installing kde-standard but this did not work either because of the package.

At last I tried force purging it and it did not work either. enter image description here

Can this be fixed in some other way or is a reinstall of debian a must?

1
dpkg --force-remove-reinstreq libopencc1  

should help to get rid of this brocken package.

  • sudo dpkg --remove --force-remove-reinstreq libopencc1 got the job done. Thanks! – S4M1R Nov 11 '16 at 20:23
  • Note the caveat in the dpkg manpage: "This may, for example, cause parts of the package to remain on the system, which will then be forgotten by dpkg." You should really re-install it; --force-remove-reinstreq is a last resort. – Stephen Kitt Nov 11 '16 at 21:58
  • Right, it is a grenade, but if apt-get -f installis not working most apt-get install --reinstall either do. – user192526 Nov 12 '16 at 10:52
1

You need to reinstall the package, without removing it:

apt-get --reinstall install libopencc1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.