I'm trying to install Freebsd on a usb stick with root on ZFS. I have FreeBSD-11.0-RELEASE-amd64-memstick.img written to an other usb stick.

When I try to install it with zfs the installer doesn't reboot (after selecting reboot from the end of the installer) Also after booting the pc again, it gives the following warning:

FreeBSD/x86 ZFS enabled bootstrap loader, Revision 1.1
([email protected], Thu Sep 29 01:38:49 UTC 2016)
Can't work out which disk we are booting from.
Guessed BIOS device 0xffffffff not found by probes, defaulting to disk0: not found
panic: Assertion failed: (FALSE), function ficlCompileSoftCore, file softcore.c, line428
--> Press a key on the console to reboot <--

When instead of installing it using root of zfs, I use ufs, the install completes. The system is bootable after that.

I had an issue with the ufs install first, that the install went fine, but when starting the system, it wouldn't be able to find the root partition. The issue was because the usb with the installation files would be da0 and the usb installing on would be da1. Then when starting the system, the usb with the installed freebsd wouldn't be da1 anymore, but da0. I solved it by putting the usb to install freebsd on in a usb slot, that's loaded first by freebsd.

The install with root on zfs wouldn't work with the usb sticks in the correct slots.

1 Answer 1


After a loooot of searching I finally found the answer. I have an HP Proliant gen 8 server. A bug is in the zfsloader that causes this error. There is a patch for it here (download). I'm using FreeBSD 11 and the patch is for 10.1 and 10.3, but the 10.3 also works for FreeBSD 11.

When rebooting the zpool would still be busy, so you have to manually export it to be able to reboot.

zpool export -f zroot

Searching for an answer I have found some interesting sites:

Edit: Ok I have my server install complete now. I installed FreeBSD again with the installer and selected Root on ZFS (guided). When installation was finished I selected the option to go into a shell. There I used the following commands to get the patched zfsloader.

cd /boot
mv zfsloader zfsloader.bak
fetch --no-verify-peer -o zfsloader https://goo.gl/TMQmib
chmod 555 zfsloader

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .