When opening my network manager on kali i get the message

Oops, something has gone wrong. Please contact software vendor.
NetworkManager needs to be running.

I've tried

service network-manager restart


service network-manager stop
service network-manager start

Still get the same error in my network manager. I have also tried

 /etc/init.d/network-manager start

Still nothing. When doing

service network-manager status

i get

Active: active (exited) since Fri 2016-11-11 05:39:00 EST; 10s ago
Process: 1744 ExecStop=/etc/init.d/network-manager stop (code=exited, status=0/SUCCESS)
process: 1747 execStart=/etc/init.d/network-manager start (code=exited, status=0/SUCCESS)

I am running the latest kali 2016.2.

  • failed to enable unit: unit file /etc/systemd/system/NetworkManager.service is masked. Nov 11 '16 at 11:16
  • @GAD3R When running systemctl enable network-manager.service' i get network-manager.service is not a native service, redirecting to systemd-syvs-install.` Nov 11 '16 at 11:18
  • @GAD3R executing: /lib/systemd/systemd-sysv-install enable network-manager. Still doesn't fix my issue. Nov 11 '16 at 11:20
  • @GAD3R After running the unmask command i got the output Removed /etc/systemd/system/NetworkManager.service Nov 11 '16 at 11:32
  • @GAD3R first i get failed to start NetworkManager.service: Unit NetworkManager.service not found and failed to enable unit: No such file or directory Nov 11 '16 at 11:38