3

I've kicked myself out of the wheel group by running usermod -G without -a (add). Now, if I change to root by su and do usermod -aG wheel myuser I get no output, as expected. Likewise, groups myuser outputs: "myuser : myuser wheel ...". However, after relogging as myuser and just typing groups gives me all other groups, but wheel!

  1. I googled a lot now and found, that wheel is the admin group of some systems. Which? Is fedora such a sys?
  2. How do I get the sudo rights back for my fedora user?

the sudoers file has (albeit others) the entries: root ALL=(ALL) ALL and the same with %wheel

To be more precise: I found a million commands adding users to various groups etc, but none worked for me. Since i do not understand the fact, that I do #su -c "usermod -aG wheel myuser" and logged in to my user I still get no wheel group after typing groups, I do not know how these things work or what is going on!

and Yeah, grep wheel /etc/group gives wheel:x:10:myuser

2
  • 1
    Not sure if you're using graphical interface. But keep in mind that all group changes are applied only after logout and login (or in completely new session). Closing / opening terminal window in existing X session doesn't work.
    – rush
    Commented Nov 10, 2016 at 21:40
  • 1
    As root, what does groups myuser show? It's not absolutely clear from your writeup that you have logged out and in as myuser after you added myuser back to wheel.
    – MikeA
    Commented Nov 10, 2016 at 23:44

2 Answers 2

2

Try rebooting. It looks like you're definitely in the wheel group. It's likely that you're just not fully logging out; shutting down will remove any doubt that you have logged out.

0

you can also doing it with the following command: gpasswd -a <username> wheel you should received something like: Adding user to group wheel

To see the user groups you can use: groups <username> ; getent passwd <username>

2
  • getent group <name> shows the group with name <name>, not the groups that a user called <name> belongs to. To see which groups a user belongs to, use groups <name> instead.
    – jayhendren
    Commented Nov 11, 2016 at 17:10
  • No needs to vote Negatively my answer ... just trying to help here
    – Orsius
    Commented Nov 11, 2016 at 17:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .