Just bought a new computer and assembled it today. Then as always I installed windows for all the graphic needs (Photoshop and Co) and now I wanted to install a dual boot with Fedora 24. Made a new USB bootable live install media and selected this uefi usb in the boot menu.

At this point it shows me regular grub menu where I can choose to start Fedora or check media and start Fedora. Tried both of them.

After a few seconds it shows me some [OK] Firewall loaded [OK] XY Loaded .... and so on. Then the mouse appears with the shell output still in background. I can move the mouse bot no Gnome Desktop appears. A few seconds later the mouse icon disappears and it has been frozen on the boot output.

I cant find any important output at this point.

Is there any way to install fedora whiteout a gui? Or can I disable the display drivers?

My setup: i7 7600K ASUS Maxmimus Hero VIII MSI Geforce GTX 1070

I tried to start the install with the build in VGA of my mainboard, but sure, there is no output.

Do you have any tips for installing Fedora on my new computer? I also tried a few ways to create the boot media, Mac dd, Windows Tool rufus, Mac Tool unetbootin and at least Windows Tool Fedora Media Writer. So I think I did not get a bad usb-iso install.

Oh and I also tried other distributions like ubuntu, which boots just fine. Also tried the newest beta of Fedora 25, but still the same error as above described.


2 Answers 2


It seems a graphic card driver issue. When you are about to boot your Fedora just in the GRUB menu, edit the entry and add a 3 at the end of the boot line, this will boot in text mode. When you reach the login do it and edit the xorg.conf with nano or vi, in the Device section under Driver change it to vesa, this is the basic default driver in Linux.

After this reboot your system and let it do it as usual, if you can access to your Gnome GUI just install the nVidia graphics via proprietary or open source drivers.


I faced the same issue in Ubuntu you can try yum install sudo if you don't have it and then follow these steps for Fedora.

So after much googling, I got the solution. It was very simple to fix that issue.

1 When the USB/CD boots press E on the grub menu it will lead to editing the grub.

2 Find the line which ends with quiet splash and add nomodeset in front of it. So it becomes nomodeset quiet splash. Whatever is there in front of it leave it as it is just add nomodeset in front of quiet splash.

3 Now press Ctrl+X to boot it normally. It will lead you to Try Ubuntu Without installing an option. Now from here to you can install Fedora. As install Ubuntu option is always there in the live session. Now after installing Fedora, we need to change nomodeset thing permanently so that we don't have to do it again.

4 After successfully installing the system will reboot. Press shift button for 5 seconds to get the grub menu after the system starts. If it does not work then try the same with Esc. The most important thing is that it is all about timing.

5 Now again repeat step 2 so that we can login in the system.

6 Now open a terminal and type sudo nano /etc/default/grub it will be having contents similar to this.

7 ind the line having quiet splash and add nomodeset in front of it.

8 Now save it with Ctrl+O and exit it with Ctrl+X. In order to update grub menu enter:

sudo update-grub

When using visudo you need to just add the following if you want to be able to run all the commands that root runs.

sparticvs ALL=(ALL) ALL

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .