When trying to upgrade my Ubuntu 15.04:

sudo do-release-upgrade

I get an error message:

An upgrade from 'vivid' to 'xenial' is not supported with this tool

I even found a bug report for this issue:


but there no solution is provided.


3 Answers 3


Well, the indirect route almost worked for me. I will describe... though it did not work at the end THat is first updating into wily version, next into xenial. There is similar answer here: https://serverfault.com/questions/892743/ubuntu-server-stuck-at-15-04-and-cannot-upgrade In detail,

delete the content of sources.list using

   sudo gedit /etc/apt/sources.list 

replace it with

     deb http://old-releases.ubuntu.com/ubuntu/ wily main restricted
     deb http://old-releases.ubuntu.com/ubuntu/ wily-updates main restricted
     deb http://old-releases.ubuntu.com/ubuntu/ wily universe
     deb http://old-releases.ubuntu.com/ubuntu/ wily-updates universe
     deb http://old-releases.ubuntu.com/ubuntu/ wily multiverse
     deb http://old-releases.ubuntu.com/ubuntu/ wily-updates multiverse
     deb http://old-releases.ubuntu.com/ubuntu/ wily-backports main restricted universe multiverse


sudo apt-get update
sudo apt-get dist-upgrade

At this point, you will have wily version of Ubuntu. Then once again

 sudo apt-get update
 sudo apt-get dist-upgrade

and you will have to type Y on questions then I got an error at restart. What really worked is that I downloaded the Ubuntu 16 iso and it allowed me to overwrite current installation while keeping all data.


It is not supported to upgrade from 15.04 to 16.04 directly. You can upgrade from lts to lts that means from 14.04 to 16.04. If you like Adventures choose your sources.list to deb http://old-releases.ubuntu.com/ubuntu wily main restricted universe multiverse and upgrade to wily 15.10 first, then you can upgrade to 16.04. But the better is way to install xenial (16.04.01) fresh after then you have save your personal Datas.

  • fresh install means reconfiguring the whole system, does not sound like a nice way
    – alex
    Commented Nov 10, 2016 at 21:19
  • 1
    dpkg --get-selections \* > $HOME/dpkg.txt under 15.04. In new xenial-installation. dpkg --set-selections < $HOME/dpkg.txt sudo apt-get dselect-upgrade So you have your packages back.
    – user192526
    Commented Nov 11, 2016 at 8:06

Solution: Make use of the following command- sudo do-release-upgrade -d

That worked for me.

  • 2
    -1 You should not recommend using -d flag with do-release-upgrade because it installs the unstable ("development") version if it works at all.
    – Zanna
    Commented Apr 11, 2017 at 8:04
  • @Zanna: Thanks for the info. Really didnt knew of the above. Thanks once again. :) Commented Apr 11, 2017 at 9:10
  • You're very welcome of course. Perhaps you could do some research and edit your answer (see my comment on the question)
    – Zanna
    Commented Apr 11, 2017 at 9:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .