1

First I had a problem with the printer and sharing files, after disabling both it is solved and no window error is shown. Then when I have tried to access from client the windows is fully black. How could I fix it? Before the black screen I get this error: enter image description here I use Gnome in CentOS 7. Here you have details of my session:

NXPROXY - Version 3.5.0

Copyright (C) 2001, 2010 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Proxy running in client mode with pid '12960'.
Session: Starting session at 'Thu Nov 10 14:37:43 2016'.
Info: Connecting to remote host 'localhost:31003'.
Info: Connection to remote proxy 'localhost:31003' established.
Info: Connection with remote proxy completed.
Warning: Unrecognized session type 'unix-kde-depth_32'. Assuming agent session.
Warning: Failed to read data from the X auth command.
Warning: Generated a fake cookie for X authentication.
Info: Using ADSL link parameters 512/24/1/0.
Info: Using cache parameters 4/4096KB/8192KB/8192KB.
Info: Using pack method '16m-jpeg-9' with session 'unix-kde-depth_32'.
Info: Using ZLIB data compression 1/1/32.
Info: Using ZLIB stream compression 4/4.
Info: Using cache file '/cygdrive/C/Users/quico/X2GO~1/cache-unix-kde-depth_32/S-08242B7859B5E7DE927D20CD213366AE'.
Info: Forwarding X11 connections to display 'localhost:0'.
Session: Session started at 'Thu Nov 10 14:37:44 2016'.
Info: Established X server connection.
Info: Using shared memory parameters 0/0K.

In my Centos 7 I use Gnome Desktop.

Here I leave how I have configured the session:

enter image description here

If you need more info, in order to help me, let me know.

2 Answers 2

2

The problem is with Gnome, installing Xfce works well.

1
  • 2
    Gnome 3 broke remote desktop access via XDMCP and X2go. An alternative desktop that works is MATE. Oct 4, 2018 at 10:32
0

You can also fix this by installing gnome-flashback on the server, and use on the client-side GNOME

This solution worked for me using the following machines:

  • Windows (Client)
  • Ubuntu 18.04 (Server)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .