0

I'm mounting my NAS/NFS share to /mnt/nas on my notebook/wlan connection. This did work until last week. Mounting the NFS share with two other wired PCs (same distro) still works.

In Debian / Arch Linux forums they suggested to add more x-systemd options to the fstab

  • noauto
  • x-systemd.automount
  • x-systemd.requires=network-online.target
  • x-systemd.device-timeout=10

My current fstab looks like this

192.168.220.100:/foo/bar /mnt/nas nfs  nfsvers=3,rsize=32768,wsize=32768,noauto,x-systemd.automount,x-systemd.requires=network-online.target,x-systemd.device-timeout=60             0 0

I've tried the following options in fstab x-systemd.requires= network-online.target or systemd-networkd-wait-online.service or nfs-client.target none of them worked.

journalctl error: mount[841]: mount.nfs: Network is unreachable

When I run a sudo mount /mnt/nas manually after boot, it mounts the share.

How can I have my NFS share mounted automatically after boot?

0

If you read this, you might probably have the same problem I had.

My hint was comming from journalctl | grep nas

systemd[1]: mnt-nas.automount: Got automount request for /mnt/nas, triggered by 746 (zeitgeist-datah)

I simply uninstalled the zeitgeist package - not sure why it was installed, and mounting works again

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.