1

We build two puppet master on openstack cloud and put them behind LBaasV2 (haproxy) load balancer, also we have separate puppetDB and PuppetCA server to handle certificate.

                        |----[puppetmaster1]
   [Agent]-----[LB]-----|  
                        |----[puppetmaster2]

now problem is when i am running puppet agent -t -v it does sending certificate sign request to puppetCA server but after running second time puppet agent getting following error

 [root@agent ~]# puppet agent -t -v
 Warning: Unable to fetch my node definition, but the agent run will continue:
 Warning: SSL_connect SYSCALL returned=5 errno=0 state=SSLv3 read server session ticket A
 Info: Retrieving pluginfacts
 Error: /File[/var/lib/puppet/facts.d]: Failed to generate additional resources using 'eval_generate': SSL_connect SYSCALL returned=5 errno=0 state=SSLv3 read server session ticket A

Does LB messing with SSL certificate? Or does it related to puppetDB issue. I haven't seen any document or any related article to setup puppet in cluster using LB.

1

Solution:

I found issue and you won't believe it was network MTU size issue.

Openstack VM use MTU 1400 default and rest of the world use MTU 1500

As soon as i change MTU 1400 on puppet client machine it works! But not sure why openstack use 1400 there must be a reason.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.