I have Linux Mint installed on 3 computers at home, and all of them are almost unusably slow whenever Firefox is open. Here is the output from top:

top output while running Web Content

As you can see, "Web Content" and Firefox are collectively using up nearly all of my CPU, and more than 50% (4GB+) of system memory.

I have never had this problem in the past with Debian or Ubuntu, but it is occuring on every computer I've installed Mint on so far. This extremely high (near total) CPU/memory usage is constant, and is rendering my computer unusable.

Does anyone have ideas about how to fix this? If there is no fix, how can I keep this "Web Content" application from running at all?

  • 2
    This happen to me with lubuntu 15 too.
    – Carlos
    Feb 13, 2017 at 13:12
  • 4
    It happens to me with Ubuntu 16.04. I don't think it is related to Mint or any other distro.
    – Georg
    Feb 16, 2017 at 21:59
  • 1
    1) I use firefox nightly, updated regularly, 2) and I turn off the e10s, because I think it is a catastrophal move. --> I never had any problem, and I have a very fast, very small firefox. I simply don't have WebContent processes and similar crap.
    – peterh
    Sep 17, 2017 at 22:33
  • 1
    What is e10s? Web search turns up nothing seemingly related. there is a Wikipedia page for it but redirects to the main Firefox page for Features, but no where is e10s listed in the Firefox wikipedia page.
    – bgoodr
    Aug 23, 2018 at 15:53
  • 1
    @bgoodr e10s == Electrolysis aka Multiprocess Firefox. support.mozilla.org/en-US/kb/…
    – doremi
    Oct 1, 2018 at 22:45

5 Answers 5


this is a common problem causing nothing but the battery wasted energy decreasing unplugged operation time significantly.

the cause of the problem appears to be very simple: you may have too many tabs opened each having bulky and useless endless loops running java-scripts.

those java-scripts are usually not origin of the web site you are working with but an ad based 3rd parties from somewhere else trying to collect some info from your FFox session or just to display switching ads on a side.

the simple (but not unique) solution would be to install NoScript plugin - causing immediate effect - Web Content process CPU consumtion will decrease almost to 0%.

so keep NoScript installed on all your FFox'es and keep track on what domain you are actually allowing scripts from to be executed very carefully.

it's a good practice to allow only original domain scripts for permanent (a choice "allow") to have the web site you are visiting to display correctly all the useful information, but to keep side or extra domains only in "forbid" or "temporary allow" mode so the next FFox load will keep all these unwelcome scripts banned again.

  • That sounds like a rather reasonable explanation.
    – Hexdump
    Jun 8, 2017 at 10:29
  • 1
    Upvoted, but in my case Ghostery was the add-on that appeared to engage the CPU while NoScript was also working. Apparently, NoScript had no control on the WebContent activities related to the functioning of Ghostery (arguably because they come from inside the system). My experience is in line with this other answer Dec 1, 2017 at 11:31
  • @Oleg Kokorin : How to I install NoScript Plugin ? Jun 9, 2020 at 14:05
  • That's my problem too. Ubuntu 20. I need (like) however to have many tabs open. Can I configure Firefox somehow to stop Java Script in tabs I am not currently looking at? Oct 7, 2020 at 18:34

I just had this problem with the "new" Firefox. The process was consuming 2.4 GB on a 4 GB machine with only one tab open. Disabling the Ghostery plugin solved the issue for me.

  • This is a good explanation for my case: I had NoScript and Ghostery up and running. Disabling Ghostery has brought the CPU usage of Web Content applications to a reasonable few percent. Hence, in my case, NoScript is useful (see post below) but could not guard against Ghostery. I use Ubuntu 14.04 LTS; the issue was felt more in a laptop than in a desktop with same Firefox and add-ons. Dec 1, 2017 at 11:27
  • Ghostery is not a tool to have. it was never suggested one. Mar 10, 2018 at 9:28
  • I had dozens of TABs open, Noscript and Ghostery running, but disabling Ghostery only had a short effect on the CPU usage of "Web Content".
    – U. Windl
    Jan 7, 2021 at 7:48

I looks like you have some problematic Firefox plugins or extension installed? Try disabling any/all extensions and see if that resolves the issue.

Edit*: Check this link for further info - looks to be flash related: https://forums.linuxmint.com/viewtopic.php?t=231186

  • Sadly this link does not make sense for me. Feb 20, 2017 at 21:22
  • It doesn't help. This happens even with the default install.
    – J. Taylor
    Apr 24, 2017 at 23:41

I had the same problem and tried to close one by one the opened tabs, to locate the one that relies heavily on Web Content process. It turned out that ebay utilize about 20-30% of my cpu, depending on your machine, this percentage can potentially be lower or higher.


I have a new update for this question:

With Firefox 75 (64 b) on Linux Mint 19 (Cin version 3.8.9) I installed NoScript a couple of days ago and then I had a WebContent upcoming and heating up my computer.

Contrary to what Oleg Kokorin posted I had to uninstall NoScript to recover Firefox with normal behavior. The only othe plugin I have is AddBlockPlus which I kept and is working fine for years.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .