4

So, I wanted to get Unreal Engine 4, but for some odd reason, clang does not want to install. I have never used clang at all before, and it isn't even installed, so I have no real clue what is happening.

Registering git hooks... (this will override existing ones!)
Attempting installation of missing package: clang-3.5
+ sudo apt-get install -y clang-3.5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 clang-3.5 : Depends: libclang1-3.5 (= 1:3.5-4ubuntu2~trusty2) but it is     not going to be installed
             Depends: libobjc-4.8-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

This is really annoying, as it has happened to me with multiple different softwares that I have tried to get through the package manager as well, not just sources.

here is my uname:

Linux hyperbeam 3.19.0-32-generic #37~14.04.1-Ubuntu SMP Thu Oct 22 09:41:40 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

2 Answers 2

3

Try manually installing the dependencies:

sudo apt-get install -y clang-3.5 libclang1-3.5 libobjc-4.8-dev

This may be caused by mixed repositories. See:

https://askubuntu.com/questions/564282/apt-get-unmet-dependencies-but-it-is-not-going-to-be-installed

Do you have a mixed /etc/apt/sources.list? It appears that you're trying to install one package from a newer repository but that it doesn't have access to a repository with the newer dependencies.

6
  • that did not work at all, it just stated more dependencies, and I think it may involve my version of linux Nov 8, 2016 at 20:50
  • sudo apt-get -f install not working?
    – Jan
    Nov 8, 2016 at 20:57
  • For me it seems that libobjc is refusing to install: libobjc-9-dev : Depends: gcc-9-base (= 9.3.0-17ubuntu1~20.04) but 9.4.0-1ubuntu1~20.04 is to be installed. Any ideas? Nov 11, 2021 at 4:54
  • @AaronFranke I am facing the same issue, did you ever find a solution for this issue? Feb 11 at 9:47
  • 1
    @ArneFischer I wiped Ubuntu 20.04 and replaced it with Ubuntu 21.10 and then it worked. Feb 11 at 17:21
0

Just run sudo apt --fix-broken install After the installations are fixed run an sudo apt update Am on Ubuntu 18.04.2 This worked for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.