0

I'm running Debian 8.6. The Sharkoon box is connected via e-sata cable. The harddisk I want to access holds an lvm2 logical volume [which was created with a different machine, also debian 8.6]. My problem is this: I can access the disk if the Sharkoon device was switched on before I powered on the computer. If it is done the other way round I can't. Is there a command that saves me from rebooting?

0

Become root (of course) e.g. via sudo -s.

Then run:

pvscan
vgscan
vgchange –available y
lvscan

pvscan looks for any LVM physical volume on attached devices.

vgscan then looks for any LVM volume groups on discovered physical volumes.

vgchange -available y marks the discovered volume groups as active.

lvscan finally looks for logical volumes in the discovered volume groups.

Now the logical volumes should be available under /dev/mapper/volgroup-logvol (where of course volgroup-logvol depends on your config).

These steps are basically performed during booting which is why you can access the logical volumes directly when the drive was available during boot.

4
  • Sorry for replying so late but this solution doesn't work for me. Maybe here's another problem hidden. I did further investgations and saw (purely by chance, using 'df') that the root filesystem once is at /dev/sda1 (Sharkoon 'off' while booting) while next time it is at /dev/sdb1 (Sharkoon 'on' while booting). With Sharkoon 'off' during boot I'm not even able to see the hd with 'fdisk -l' after turning the device on. It's a complete riddle to me. I now think it could have to todo with BIOS settings but I'm not very expirienced at that topic. Otherwise your solution is correct.
    – schatt
    Nov 10 '16 at 11:02
  • Check what happens if you first unplug the eSATA cable, then turn it on, then insert the eSATA cable. Also check the dmesg -ew output for any messages during this action (i.e. first start dmesg -ew, then plug in the cable).
    – wurtel
    Nov 18 '16 at 15:34
  • No change. I followed your instructions. dmesg -ew simply remains silent.
    – schatt
    Nov 20 '16 at 14:10
  • Looks like a hardware issue with your esata port, unfortunately.
    – wurtel
    Nov 28 '16 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.