3

I'm running Jessie with MATE. The volume keys themselves are functional but they don't change the volume, and while I can use the volume control widget it's inconvenient. My problem is similar to this issue except I have pulseaudio installed.

Now, I did delete pulseaudio at one point, but I later reinstalled it, so I don't know how to fix this. I believe it installed packages to replace pulseaudio when I deleted it and maybe there's a conflict? The keys themselves work and are correctly mapped in my keyboard shortcuts. The megaphone icon thing appears on the screen when I press the volume keys, but the volume won't change.

xev output: (mute/volume up/volume down all return the same thing)

KeymapNotify event, serial 43, synthetic NO, window 0x0,
keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
       0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   

#1 SMP Debian 3.16.36-1+deb8u2

  • The issue you linked to was likely caused by removal of gnome packages related to pulseaudio, not by removal of pulseaudio itself. Do you get ACPI events or X events for your volume keys (run xev, move mouse cursor into window, press keys)? If it's the latter, you need to somehow configure mate to react to the X events. – dirkt Nov 7 '16 at 21:12
  • Do the keys work if you create a new user and log in using that? – Stephen Kitt Nov 8 '16 at 12:21
  • I confirm they don't. – trudgemank Nov 8 '16 at 12:47
  • What does dpkg --get-selections | grep mate | grep pulse list? There are a couple of MATE pulseaudio packages in the repository. Not running MATE myself, but from the description mate-settings-daemon-pulse might be important. (If anyone actually knows, please don't let this comment prevent you from posting an answer!) – derobert Nov 9 '16 at 17:19
  • @derobert mate-media-pulse install – trudgemank Nov 10 '16 at 17:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.