2

I don't know how to properly debug the kernel configuration process when an option that should be on ( because it doesn't really depends on anything and it doesn't conflict with anything that I can think of ) , really can't find a way to live beyond make olddefconfig .

Among other things I'm using

CONFIG_SYS_SUPPORTS_ZBOOT=y

with a 4.8.6 kernel tree and I found no way to write a .config file that will retain this specific flag on after using make and according to the available documentation and scripts in the arch/mips this shouldn't happen .

Since this option is required in order to generate vmlinuz for mips targets I have enabled lzma for the kernel for both compression and decompression but so far ... nothing, CONFIG_SYS_SUPPORTS_ZBOOT=y keeps on "going off" .

Do you have any idea how I can literally force a CONFIG flag to stay on or how to debug why make and kbuild are thinking that this flag can't be on ?

1

Manually changing the .config file without Kconfig is discouraged as it might lead to unexpected behavior. In your case the best solution would be to run

make menuconfig

and selecting the configuration option from the menuconfig (the parameter you are looking for should be under arch/mips).

2

You can't.

SYS_SUPPORTS_ZBOOT doesn't have any prompt so it is not user selectable.

That option is supposed to be selected by your platform (Machine selection, System type choice). If this is not the case, it probably mean that this is not supported by your machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.