I dual-boot kali linux with windows 10. After installation wifi is not working. I can run internet by using USB modem. It's surprising because during its installation i provided all the required firmwares for wifi and ethernet which installer was asking. The rest of the firmwares which were still missing, i copied them to /lib/firmware after installation. I've Intel Dual-Band Wireless AC-3165 wifi adapter.

0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
2: acer-wireless: Wireless LAN
Soft blocked: yes
Hard blocked: no
  • please add the output of uname -a
    – GAD3R
    Nov 6, 2016 at 17:19
  • Can you add the output of cat /etc/apt/sources.list?
    – GAD3R
    Nov 7, 2016 at 16:29
  • can you add output of rfkill list?
    – defalt
    Dec 2, 2016 at 10:43

3 Answers 3


Your Terminal output rfkill list shows the following issue:

The GNU/Linux kernel is loading the acer_wmi kernel module, even though you are NOT using Acer hardware.

Both the acer_wmi and intel_wmi kernel modules are running at the same time, causing a conflict and causing the wireless adapter to get deactivated by the acer_wmi kernel module.

However, you are using an intel adapter, not an NIC by Acer.

So the acer_wmi module needs to be blacklisted (= prevent it from starting during boot).

Please copy-paste the following command into the Terminal and then press ENTER:

gksudo gedit /etc/modprobe.d/blacklist.conf

Using the gedit editor, please scroll down and ADD the following configuration line into the file /etc/modprobe.d/blacklist.conf:

blacklist acer_wmi

Using the gedit editor, SAVE the change to the /etc/modprobe.d/blacklist.conf file.

Then REBOOT and retest wireless. This blacklist operation should make the change permanent, even after rebooting.

This should force the Linux kernel to stop loading the acer_wmi module, which is probably causing the kernel to soft block your wireless adapter.

The acer-wireless interface is an invalid wireless interface on your computer, because you are not using ACER hardware.


Download the firmware from here or from here

wget https://wireless.wiki.kernel.org/_media/en/users/drivers/iwlwifi-7265-ucode-16.242414.0.tgz
tar xvf iwlwifi-7265-ucode-16.242414.0.tgz

copy it to your /lib/firmware

cp iwlwifi* /lib/firmware

install the required package build-essential and linux-headers :

sudo apt-get install build-essential

Run apt-cache search linux-headers then install it

Download and compile backports:

wget https://www.kernel.org/pub/linux/kernel/projects/backports/2016/03/24/backports-20160324.tar.gz
tar xvf backports-20160324
cd backports-20160324
make defconfig-iwlwifi
make install



Open the sources.list file:

apt edit-sources

Choose the text editor e,g : 1 (nano) add the following line ( verify it):

deb http://http.kali.org/kali kali-rolling main contrib non-free

Save it then run the following commands :

apt-get update
apt-get upgrade
apt-cache search linux-headers

Then install the appropriate linux-headers e,g:

apt-get install linux-headers-4.8.0-kali1-amd64
apt-get install linux-image-4.8.0-kali1-amd64

Reboot your system , from the advanced option Boot Kali-linux with the 4.8.0 kernel version then compile backports .


Blacklist acer_wmi solve the problem

  • It worked. It is downloading new upgrade packages. I'm sure rest of the command-lines will work after upgrade is done.
    – defalt
    Nov 9, 2016 at 2:29
  • @user334283 after editing the sources.list are you able to found/ install the linux-headers ?
    – GAD3R
    Nov 18, 2016 at 19:18
  • I'm able to install linux-headers with a little search on internet. Now I'm supposed to download and compile backports but each time I enter the command-line make after extracting, it displays errors as shown in the screenshot. See above. I think I'm on the last step of your answer.
    – defalt
    Nov 18, 2016 at 20:08
  • 1
    This is the error i was talking about. pastebin.com/jsnKt816 . I maybe new to shell commands but that's not tough to guess that these are compile-time errors. Codes of backports have errors.
    – defalt
    Nov 26, 2016 at 14:17
  • 1
    I fixed it. See my answer. Backports were never really a problem. Backports are not even required for the latest kernel module.
    – defalt
    Dec 2, 2016 at 10:55

No need for anything complex, you can install the firmware package directly with apt.

The commands to install the firmware are:

sudo apt-get update
sudo apt-get install firmware-iwlwifi

The commands to reload the driver are:

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi
  • output of your commandlines: root@defalt:~# sudo apt-get update Reading package lists... Done root@defalt:~# sudo apt-get install firmware-iwlwifi Reading package lists... Done Building dependency tree Reading state information... Done firmware-iwlwifi is already the newest version (20160712-0kali1). 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. root@defalt:~# sudo modprobe -r iwlwifi modprobe: FATAL: Module iwlwifi is in use. root@defalt:~# sudo modprobe iwlwifi
    – defalt
    Nov 7, 2016 at 16:28
  • By the sounds of the errors the wifi interface is up already, try a reboot or ifdown wlan0 before unloading the module Nov 7, 2016 at 18:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .