I'm trying to install Guest Additions, the guest SO is Fedora 24 and the host SO is Windows 7.

I'm doing this to fix the screen resolution in Fedora because the maximum I can get is 1024x768, while in Windows I have 1366x768.

The problem is that when I try to install Guest Additions I get this:

Verifying archive integrity... All good.
Uncompressing VirtualBox 5.0.26 Guest Additions for Linux............
VirtualBox Guest Additions installer
Removing installed version 5.0.26 of VirtualBox Guest Additions...
Removing existing VirtualBox DKMS kernel modules[  OK  ]
Removing existing VirtualBox non-DKMS kernel modules[  OK  ]
Copying additional installer modules ...
Installing additional modules ...
Removing existing VirtualBox DKMS kernel modules[  OK  ]
Removing existing VirtualBox non-DKMS kernel modules[  OK  ]
Building the VirtualBox Guest Additions kernel modules
Building the main Guest Additions module[FALLÓ]
(Look at /var/log/vboxadd-install.log to find out what went wrong)
Doing non-kernel setup of the Guest Additions[  OK  ]
Press Return to close this window...

So everything is fine except Building the main Guest Additions module

This is in /var/log/vboxadd-install.log:

Uninstalling modules from DKMS
Attempting to install using DKMS

Creating symlink /var/lib/dkms/vboxguest/5.0.26/source ->

DKMS: add completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...
make -j2 KERNELRELEASE=4.8.4-200.fc24.x86_64 -C /lib/modules/4.8.4-200.fc24.x86_64/build M=/var/lib/dkms/vboxguest/5.0.26/build......(bad exit status: 2)
Error! Bad return status for module build on kernel: 4.8.4-200.fc24.x86_64 (x86_64)
Consult /var/lib/dkms/vboxguest/5.0.26/build/make.log for more information.
Failed to install using DKMS, attempting to install without
grep: /lib/modules/4.8.4-200.fc24.x86_64/build/include/linux/version.h: No such file or directory
make KBUILD_VERBOSE=1 CONFIG_MODULE_SIG= -C /lib/modules/4.8.4-200.fc24.x86_64/build SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 modules
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (                \
echo >&2;                                                       \
echo >&2 "  ERROR: Kernel configuration is invalid.";           \
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";      \
echo >&2 ;                                                      \
mkdir -p /tmp/vbox.0/.tmp_versions ; rm -f /tmp/vbox.0/.tmp_versions/*
make -f ./scripts/Makefile.build obj=/tmp/vbox.0
  gcc -Wp,-MD,/tmp/vbox.0/.VBoxGuest-linux.o.d  -nostdinc -isystem /usr/lib/gcc/x86_64-redhat-linux/6.1.1/include -I./arch/x86/include -I./arch/x86/include/generated/uapi -I./arch/x86/include/generated  -I./include -I./arch/x86/include/uapi -I./include/uapi -I./include/generated/uapi -include ./include/linux/kconfig.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -std=gnu89 -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -mno-avx -m64 -falign-jumps=1 -falign-loops=1 -mno-80387 -mno-fp-ret-in-387 -mpreferred-stack-boundary=3 -mskip-rax-setup -mtune=generic -mno-red-zone -mcmodel=kernel -funit-at-a-time -maccumulate-outgoing-args -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -DCONFIG_AS_FXSAVEQ=1 -DCONFIG_AS_SSSE3=1 -DCONFIG_AS_CRC32=1 -DCONFIG_AS_AVX=1 -DCONFIG_AS_AVX2=1 -DCONFIG_AS_SHA1_NI=1 -DCONFIG_AS_SHA256_NI=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -fno-delete-null-pointer-checks -Wno-maybe-uninitialized -O2 --param=allow-store-data-races=0 -Wframe-larger-than=2048 -fstack-protector-strong -Wno-unused-but-set-variable -Wno-unused-const-variable -fno-omit-frame-pointer -fno-optimize-sibling-calls -fvar-tracking-assignments -g -pg -mfentry -DCC_USING_FENTRY -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fconserve-stack -Werror=implicit-int -Werror=strict-prototypes -Werror=date-time -Werror=incompatible-pointer-types -DCC_HAVE_ASM_GOTO -Wno-declaration-after-statement -include /tmp/vbox.0/include/VBox/VBoxGuestMangli

So I guess that it can't find include/generated/autoconf.h or include/config/auto.conf files, what can I do?

I've already done:

yum install dkms binutils gcc make patch libgomp glibc-headers glibc-devel kernel-headers kernel-devel

What else can I do?

3 Answers 3


The same thing occurs on newest version of VirtualBox (5.1.8) with Windows 10 as host system. With the same error as OP I didn't managed to get it working on 4.8.6 kernel, but when I returned to older 4.5.5 one, installation went smooth and everything works as expected (tested resizing window and shared clipboard). For now, I am sticking to older kernel.

  • I solved the problem by upgrading from 5.1.8 to 5.1.14. Commented Jan 31, 2017 at 18:48

I've just had a similar issue, with Fedora 24 on kernel 4.8.7, with Virtual Box 5.0.28 from a Windows 8.1 host.

I got it working by:

  • Removing the current guest additions (VBoxLinuxAdditions.run uninstall in the CD directory)
  • Installing Virtual Box 5.1.8
  • Checking that dkms, gcc, kernel-devel, kernel-header are the latest version
  • Then finally installing guest additions 5.1.8 from the ISO that comes with VirtualBox

Uninstall VirtualBox-5.0 and install VirtualBox-5.1

  • 2
    Will this solve the problem that's described, or is it just a general statement? Commented Nov 17, 2016 at 15:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .