1

I have a recent install of Debian 8, with xfce.

All was fine, until I implemented this answer, because I wanted to get a more updated package from testing. As suggested there, I created the .list files.

After completing that procedure, I run a sudo apt-get update. There was an error, which I cannot remember precisely. But the update got stuck at (98%) [Waiting for headers] [Waiting for headers] or something like that.

Then, I decided to restart. After logging in , I got:

Xsession: warning: unable to write to /tmp: Xsession may exit with an error

After a few attempts logging in, I restarted again. Then, the GUI did not appear; there was an error - "tty7 does not exist".

Then, I logged in into tty1, and typed start. A screen full of errors appeared, including many (EE) Fatal server error and Inconsistency detected by ld.so: dl-close.c: 762: _dl_close: Assertion map->l_init_called failed!

Then, I attempted to install lightdm, as some forums suggest. If I run with root, I get the error:

Bus errorackage lists... 1%

If I run with sudo, I get:

E: Write error - write (28: No space left on device)
E: Can't mmap an empty file
E: Failed to truncate file - ftruncate (9: Bad file descriptor)
E: The package lists or status file could not be parsed or opened.

Running the command df -h, I get that /dev/sda1/ is used entirely (100%, 9.1G).

I have tried cleaning the cache, the /var/log folder, and the /tmp folder, as many posts indicate, but no progress.

Additionally, if I use Tab to autocomplete folders or files, I get:

bash: cannot create temp fil for here-document: no space left on device

Any idea how to proceed?

PS: additionally, I got several screen flashes, changing from black to gray to white... while I am in a tty console.

  • Please take a look here – JustMe Nov 6 '16 at 14:26
  • Well, the problem was really of low space. I thought Debian space allocation was like that of Ubuntu. I installed heavy things in /usr/local, which made the / quite heavy. I had to reinstall to reallocate space. – luchonacho Nov 6 '16 at 16:19
  • @luchonacho I hope you used LVM when you did the re-install. LVM is an awesome tool that can help you when faced with these problems. A simple livecd reboot (using [systemrescuecd] (system-rescue-cd.org/SystemRescueCd_Homepage) can drop you to an environment when you can extend your partitions and filesystems, obviating a need to do a re-install. – SACHIN GARG Nov 7 '16 at 0:42
1

Your disk is full. Many programs can't cope.

To at least allow the creation of temporary files, make /tmp an in-memory filesystem. That's a good idea anyway: files in /tmp don't need to be saved across restarts so they don't need to be on disk. While you repair your system, just mount it manually:

mount -t tmpfs -o mode=1777 /tmp

Now you'll be able to start the GUI. Either it'll start automatically (those flashes were the display manager attempting to start and failing) or you can run startx after logging in to start a GUI session.

There's a reserved quota of space for root, which is 5% by default. If your disk was chock full, you'll need to free more than 5% to allow your account to write to the disk. It's a good idea not to go beyond 95% anyway as performance decreases with near-full filesystems.

Depending on your constraints, you can either delete things you don't need (old logs, old downloaded packages in /var/cache/apt/archives, possibly other things under /var/cache, uninstall software that you don't use, …) or enlarge the system partition. Don't remove things if you aren't sure what they do.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.