1

After updating Arch Linux xfce4 has been crashed and When I reboot the machine I got this message

Failed to start loading kernel modules

This is the output of uname -a

Linux NasserLaptop 4.8.4-1ARCH #1SMP PREEMPT Sat Oct 22 18:26:57 CEST 2016 x86_64 GNU/Linux

Output of `pacman -Q Linux

linux 4.8.6-1

I have tried pacman -S linux and remount the /boot but still have the same problem

4
  • /boot wasn't mounted when you upgraded the kernel. Chroot in, mount /boot and run pacman -S linux.
    – jasonwryan
    Commented Nov 6, 2016 at 6:17
  • When I try arch-chroot it gives me command not found
    – Nasser
    Commented Nov 6, 2016 at 6:24
  • You have to run it from a live medium... See: wiki.archlinux.org/index.php/Change_root
    – jasonwryan
    Commented Nov 6, 2016 at 6:29
  • I have created a dir in /many/boot then mount the /dev/sda1 and then pacman -S linux the. Exit chroot and genfstab /many/boot >> /etc/fstaband umount it then reboot but still have the same problem
    – Nasser
    Commented Nov 6, 2016 at 7:00

1 Answer 1

0

I have solved ,Thank to u guys I have booted from USB then remounting the partitions as in installation then generate fstab file and edit it to add /boot then arch-chroot and pacman -S linux The problem was that boot partition didn't mount correctly and I have to edit fstab file to add it

My post and more details here in the Arch forums

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .