0

I placed a call to a bash script in my ~/.profile.

The script executes a CLI program to dim my screen at login. However, Gnome doesn't continue to log me in to my standard desktop after running the script.

Is there a way to make the ~/.profile script call non-blocking? I'm happy to provide more details that might help you answer this. My distro is Linux Mint.

Edit

Contents of .profile.

# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# Me
bash /home/eoin/repos/scripts/autostart.sh

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
    . "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi

And my script /home/eoin/repos/scripts/autostart.sh:

#!/bin/bash
bash ~/repos/scripts/redshift/redshift.sh

Which in turn calls another script :-P

#!/bin/bash
redshift -v
  • Please provide the script and the .profile. – Renan Feb 19 '12 at 19:49
  • 1
    Background your script. The shell is waiting for it... – jasonwryan Feb 19 '12 at 20:34
3

Background the script, i.e.

# Me
bash /home/eoin/repos/scripts/autostart.sh &

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.