5

I've recently installed (dualboot) Linux Mint 18 on my Sony Vaio svt15115cxs and noticed that it's running louder than on windows, so I checked the temps, and found, that while under load (eg. watching a 1080p/720p youtube vid in firefox on both systems) the CPU runs about 10 °C hotter. (measured with Psensor and watch -d -n 1 sensors on linux, and hwinfo64 on windows). So I've installed TLP and thermald but not much has changed. I've also enabled intel-microcode in the driver manager and installed the latest intel graphics dirver.

What can I do to optimize temps on linux without severely hindering the performance? I really like linux so far, but if it means higher temps then I'll have to stick with windows.

edit: Kernel:4.4.0-45 generic

edit2: So I just installed manjaro (xfce) and it stays around 72°, which is better than the mint's 77, but it's still way worse than the 52° on win.

12
  • Is this for watching videos on YouTube only or is it a general observation?
    – pfnuesel
    Commented Nov 5, 2016 at 13:45
  • Consider that it may not be the processor. That it could be the graphics chip. A few laptops have separate fans so it is easy to tell which is warming up. Otherwise check if Psensor can "see" the CPU and GPU separately. Some open-source graphics drivers are not as good as proprietary drivers. Some graphics companies have distributed proprietary drivers for Linux. You might check on this as most Linux distributions do not (can not?) distribute / install the proprietary drivers.
    – st2000
    Commented Nov 5, 2016 at 13:47
  • What kernel does it use? I found, on a different distro, that using a backported kernel did lower the temperature. However, it still seemed higher than on Windows.
    – SauceCode
    Commented Nov 5, 2016 at 16:17
  • @pfnuesel it's a general observation, I just found watching videos a quick & easy way to compare the two OS.
    – Dan
    Commented Nov 5, 2016 at 16:20
  • @st2000 The notebook only has the integrated intel HD 4000 and psensor doesn't list any GPUs
    – Dan
    Commented Nov 5, 2016 at 16:28

1 Answer 1

2

I would try two things:

  1. Install powertop and run it with powertop --auto-tune. For my laptop I'm using it with crontab: @reboot /usr/sbin/powertop --auto-tune --quiet 1>/dev/null 2>&1
  2. Use a desktop environment that lets you disable 3D compositing, so you save CPU/GPU power and heat at the cost of a slightly less "modern" desktop :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .