1

I am currently using single NFS based PXE boot on eight nodes. I followed the guide on https://help.ubuntu.com/community/DisklessUbuntuHowto

Each nodes has a 1G and 10G network. Both of them are plugged in, i want to use 1G port for IPMI only and 10G for the regular networking.

But as the system boots, it activates both interfaces and assigns DHCP generated ip. How do i disable the first NIC on linux.

eno1      # 1G
enp7s0    # 10G

I have my BIOS set to PXE from 10G only, and it is working as expected.

So far i have tried following in /network/interfaces (Different trials).

iface eno1 inet manual

iface eth0 inet manual

iface enp7s0 inet manual

auto enp7s0    
iface enp7s0 inet dhcp

I would rather have eno1 disabled or as backup interface instead of default on.

Thank you

0

Documentation is here:

man 5 interfaces

config file to edit:

/etc/network/interfaces

example config;

iface bob0 inet static

skip providing any ip, the device is static rather than dhcp and has no ip...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.