2

This morning Cinnamon won't start and keeps crashing.

It is the dialog that says it crashed and if I would like to restart; click yes and it crashes again.

Cinnamon crashed after nvidia drivers installation Discusses installing ppa:bumblebee/stable but the post is quite old now, is this still relevant?

Below is the output from lshw -C video as root

john Desktop # lshw -C video
  *-display UNCLAIMED     
       description: 3D controller
       product: GM107M [GeForce GTX 860M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:d0000000-d0ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:4000(size=128) memory:b2000000-b207ffff
  *-display
       description: VGA compatible controller
       product: 4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:32 memory:d1000000-d13fffff memory:c0000000-cfffffff ioport:5000(size=64)

This guy suggested removing the .cinnamon folder from the user directory.

I have to admit, I am reasonably comfortable in the Linux server world, but quite new to Linux desktop GUIs.

Does anyone have any suggestions on where I should start to debug this? I would rather not have to reinstall the whole OS to fix this!

  • Well, did you try removing the .cinnamon folder? – pfnuesel Nov 5 '16 at 10:57
  • Yup, but no joy.. does the same thing. – John Nov 5 '16 at 11:04
  • wiki.ubuntu.com/Bumblebee#Installation This solved the issue. – John Nov 5 '16 at 11:21
  • Please write the answer to your question, explaining in your words what happened. – Rui F Ribeiro Nov 5 '16 at 12:02
1

wiki.ubuntu.com/Bumblebee#Installation This solved the issue.

Not really got any idea why Bumblebee works over the official nVidia drivers, but install it and reboot and cinnamon magically works again.

If anyone wants to explain why.. would love to know ;)... @Rui F Ribeiro

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.