3

I want to make my own script to handle brightness. The problem is, regardless of whether I check the box in xfce4-power-manager, the former sets up keybindings for the brightness keys that I do not know how to overwrite. If I kill the process, my script works fine.

Any help is appreciated.

Info:

uname -a:

Linux Hermes 4.8.6-1-ARCH #1 SMP PREEMPT Mon Oct 31 18:51:30 CET 2016 x86_64 GNU/Linux

pacman -Q | grep xfce4:

libxfce4ui 4.12.1-2
libxfce4util 4.12.1-1
xfce4-appfinder 4.12.0-4
xfce4-artwork 0.1.1a_git20110420-4
xfce4-battery-plugin 1.1.0-1
xfce4-clipman-plugin 1.4.0-1
xfce4-cpufreq-plugin 1.1.3-1
xfce4-cpugraph-plugin 1.0.5-4
xfce4-datetime-plugin 0.7.0-1
xfce4-dev-tools 4.12.0-1
xfce4-dict 0.7.2-1
xfce4-diskperf-plugin 2.6.0-1
xfce4-eyes-plugin 4.4.5-1
xfce4-fsguard-plugin 1.1.0-1
xfce4-genmon-plugin 3.4.0-3
xfce4-indicator-plugin 2.3.3-2
xfce4-mailwatch-plugin 1.2.0-7
xfce4-mixer 4.11.0-3
xfce4-mount-plugin 0.6.7-4
xfce4-mpc-plugin 0.5.0-1
xfce4-netload-plugin 1.3.0-1
xfce4-notes-plugin 1.8.1-2
xfce4-notifyd 0.3.3-1
xfce4-panel 4.12.1-1
xfce4-power-manager 1.6.0.41.g9daecb5-1
xfce4-screenshooter 1.8.2-3
xfce4-sensors-plugin 1.2.6-3
xfce4-session 4.12.1-4
xfce4-settings 4.12.1-1
xfce4-smartbookmark-plugin 0.5.0-1
xfce4-systemload-plugin 1.2.0-1
xfce4-taskmanager 1.1.0-1
xfce4-terminal 0.8.1-1
xfce4-time-out-plugin 1.0.2-2
xfce4-timer-plugin 1.6.0-4
xfce4-verve-plugin 1.1.0-1
xfce4-wavelan-plugin 0.6.0-1
xfce4-weather-plugin 0.8.8-1
xfce4-whiskermenu-plugin 1.6.0-1
xfce4-xkb-plugin 0.7.1-2
  • Are your sure in xfce binds the keys and not the hardware itself? – Ipor Sircer Nov 5 '16 at 5:17
  • Are you suggesting my keyboard controller is somehow wired into my sound card? – Marcel Nov 5 '16 at 6:22
  • You've talked about brightness. Does your soundcard have any brightness? – Ipor Sircer Nov 5 '16 at 6:42
  • Sorry I posted a similar question about volume recently and go confused. Is what you are saying possible? – Marcel Nov 5 '16 at 15:13
1

Go to settings --> Settings Editor --> xfce4-power-manager --> handle-brightness-keys and uncheck it.

EDIT: This also doesn't work. "Volume up" button is fine, but "Volume down" button is still somehow dependent on power manager and unable to set custom shortcut via xfce keyboard shortcuts...

1

I've set up the following shortcuts in Settings -> Keyboard -> Application Shortcuts:

enter image description here

This did not work in the first place because xfce4-power-manager still captured the key and the brightness notification showed up. I had to log-out and log-in again to make it work. Now the brightness can be controlled but there is no notification anymore (which I don't mind).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.