0

I've tried making backups using the default tools in my Linux distro (Mint 17.3), and I seem to have run into a problem. It took me awhile to figure out why, but apparently it's trying to follow some of my links, which point to various places on the root drive and tries to back them up too. Considering that my /home/$USER folder is currently several hundred GB in size, my last backup was nearly ago, and my disk was under heavy use for awhile due to a known issue with ASRock mobos spamming the logfiles, I'm a bit concerned for the safety of my data and would like to get started soon.

I've tried the GUI tool and I've tried tar, cp, and 7z (no flags on any because I don't know which ones to use and the man pages can be pretty dense), but I don't know what other ways there are of doing this that I haven't tried. If it matters, the links I know it's hanging on were created by POL and Steam (I can't tell you whether they're hard, soft, or symbolic), though I think there are others that will mess it up too. The source and destination drives are both EXT4, though I experienced the same problem when the destination drive was an NTFS.

Clearly, the reason the operation is aborting due to a permission error when trying to access / . However, even if I was to run this as root, the backup operation would simply find its way back to / and recursively back everything up until my external drive is full. I need some way to prevent it from following links, but to just copy them as-is.

I just need a simple archive of my home folder I can copy back over if my current hard drive dies. I don't need a bootable backup, my system settings are only lightly modified and is easy to get back in order if I need to reinstall. The best solution is something I already have, the next-best would be free software in the repos, the next best would be a source-distributed free software tool, and if none of those are available, a trusted commercial tool of some sort.

2

I would simply use rsync. It's simple, fast and does exactly what you want. Here's how a command could look like

rsync -avz --delete /home/user /mnt/bkp

See man rsync for the meaning of the flags. -avz is quite standard. Note that I added the --delete option as well, that means when you delete a file in your home directory and you make a backup, it will also be removed from your backup. Be careful when testing!

  • 1
    @VHS A couple of additional pointers: the -a flag equals -rlptgoD. Among those 7(!) flags, -l means 'copy symlinks as symlinks' which seems relevant to your situation. In terms of being careful when testing, I'd also draw your attention to the -n flag which performs a dry-run. See full details with man rsync – SauceCode Nov 5 '16 at 2:08
  • Thanks, this is exactly what I needed. I'm not sure why it didn't archive anything (that's what -a is supposed to do, right? That's what the man page says), but I can compress my own files. I would have responded sooner, but I had to run rsync twice (the first time it said a few files failed), the second time without the -v to see why. Turned out I had a few files that had root as the owner, for some reason, but they're not important so I deleted them. – VHS Nov 7 '16 at 2:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.