5

Today i did update and glx stopped working for non-root users:

$ glxinfo
name of display: :0
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  81
  Current serial number in output stream:  82

but when i run it as root, all is good:

$ sudo glxinfo
name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
...
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GT 430/PCIe/SSE2
OpenGL core profile version string: 4.2.0 NVIDIA 304.132
OpenGL core profile shading language version string: 4.20 NVIDIA via Cg compiler
...

ubuntu 14.04. but same problem was reported for opensuse here

$ uname -a
Linux xxx 4.4.0-45-generic #66~14.04.1-Ubuntu SMP Wed Oct 19 15:05:38 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

the only non commented line of /etc/X11/Xwrapper.config is

allowed_users=console

and there is no group or user with that name.

nvidia devices permissions:

$ ls -l /dev/nvid*
crw-rw-rw- 1 root root 195,   0 lis  5 00:24 /dev/nvidia0
crw-rw-rw- 1 root root 195, 255 lis  5 00:24 /dev/nvidiactl
  • The closed-source nvidia drivers create a couple of devices in /dev. First step would be to check the permission of these devices, and make sure non-root users can access them (there should be a group for it, add them to this group). – dirkt Nov 5 '16 at 6:03
  • What is the ouput of cat /etc/X11/Xwrapper.config? – GAD3R Nov 5 '16 at 10:21
  • i added the output to the initial question – piotrek Nov 5 '16 at 12:40
  • Maby ACL Problem. Unter /lib/udev/rules.d mußt be a udev-rule for nvidia. Can you post it? Und show getfacl /dev/nvidia0 and getfacl /dev/nvidiactl searching in the fog. – user192526 Nov 5 '16 at 20:00
4

this one solved the problem for me:

Apparently the only solution at the moment is to downgrade to the previous driver version (304.131).

You can find the 304.131 drivers for Ubuntu this way:

  • go to https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-304/+publishinghistory
  • look for the version you need, and click on the version number
  • on the next page, look under "Builds" for your Ubuntu release, then click on the amd64 or i386 link behind the release name
  • on the next page, look under "Built files" for the .deb file starting with "nvidia-304_304.131". Download that file.
  • open a terminal and run sudo dpkg -i *path-to-downloaded-.deb-file* to install the downloaded version

later just lock the package version: sudo apt-mark hold nvidia-304. when nvidia fixes its driver, don't forget to unlock the package: sudo apt-mark unhold nvidia-304

3

After spending hours on that issue, i finally managed to get a glx setup working by downgrading nvidia-current (nvidia-304) from 132 to 131.

Another complain from a fedora guy: https://devtalk.nvidia.com/default/topic/974456/f24-permission-problems-/?offset=3

So this seems to confirm the "multi distro" issue, related with bug 1835736 tracked by nvidia but undocumented at the time of this writing.

304.131 debs for ubuntu's can still be grabbed from : http://ubuntu.ip-connect.vn.ua/pool/restricted/n/nvidia-graphics-drivers-304/

This will correct the issue for your 14.04.

Then :

aptitude hold nvidia-opencl-icd-304 nvidia-current nvidia-304 nvidia-304-dev nvidia-304-updates nvidia-304-updates-dev libcuda1-304

To enable all "non-nvidia driver update", and then :

aptitude unhold nvidia-opencl-icd-304 nvidia-current nvidia-304 nvidia-304-dev nvidia-304-updates nvidia-304-updates-dev libcuda1-304

To re enable "nvidia driver update" as soon as a distro / nvidia patch has been released.

My 2¢.

  • but aptitude hold will lock version to the current one (the non-working one). how can i downgrade? – piotrek Nov 6 '16 at 1:25
  • 1
    You have xenial right? sudo apt install nvidia-304=304.131-0ubuntu3 wil downgrade the driver. – user192526 Nov 6 '16 at 9:32
  • nope, as stated in the question: 14.04 – piotrek Nov 6 '16 at 13:41
  • i tried both 304.131-0ubuntu0.14.04.1 and 304.131-0ubuntu0.14.04.2 but result is the same: E: Version '304.131-0ubuntu0.14.04.2' for 'nvidia-304' was not found – piotrek Nov 6 '16 at 14:03
  • By the way, you can also download the old driver version directly from Ubuntus package management site; see the description at askubuntu.com/a/846303/227803 . – oliver Nov 6 '16 at 18:10
2

nvidia-304.134 solves this problem.

I unheld the older nvidia driver version I had downgraded to according to other answers here and installed the update from the repositories for Ubuntu 14.04. Seems good now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.