1

I recently installed Linux Debian on my Lark Ultimate 7i WIN tablet, that was originally running windows, but Windows was so much laggy on this device.
I succesfully installed Debian with LXDE, that was running beautifully on this device, with almost no cpu usage and no ram usage. But I ran into a problem with internet connection.

I went to this site, and I got that the device is using REALTEK RTL7832BS chipset. I searched almost entire internet for results, but nothing worked for me. I only found this driver to work for some guy over the world.
I successfully installed build-essential package on my system using computer with internet by porting .deb packages to the tablet. I also ported that driver git package here, and ran make inside that driver directory, but I got this output:

make: Warning: File 'Makefile' has modification time 88116208 s in the future. 
make ARCH=i386 CROSS_COMPILE= -C /lib/modules/3.16.0-4-686-pae/build M=/home/main/drv/drvWORK modules
make[1]: Entering directory '/usr/src/linux-headers-3.16.0-4-686-pae'
make[1]: Warning: File 'Makefile' has modification time 88116208 s in the future. 
make[2]: Warning: File 'Makefile' has modification time 88116208 s in the future. 
Entering directory '/usr/src/linux-headers-3.16.0-4-686-pae'
/usr/src/linux-headers-3.16.0-4-common/scripts/gcc-version.sh: line 25: gcc-4.8: command not found
/usr/src/linux-headers-3.16.0-4-common/scripts/gcc-version.sh: line 26: gcc-4.8: command not found
/usr/src/linux-headers-3.16.0-4-common/arch/x86/MakeFile:121:stack-protector enabled, but compiler support broken...
/usr/src/linux-headers-3.16.0-4-common/Makefile:647: Cannot use CONFIG_CC_STACKPROTECTOR_REGULAR: -fstack-protector...
make[3]: gcc-4.8: Command not found
make[3]: Warning: File 'scripts/Makefile.lib' has modification time 59474584 s in the future.
CC [M] /home/main/drv/drvWORK /core/rtw_cmd.o
/bin/sh: 1: gcc-4.8: not found
/usr/src/linux-headers-3.16.0-4-common/scripts/Makefile.build:262: recipe for target '/home/main/drv/drvWORK/core...
failed
make[4]: *** [/home/main/drv/drvWORK/core/rtw_cmd.o] Error 127
Makefile:181: recipe for target 'sub-make' failed
make[2]: *** [sub-make] Error 2
Makefile:8: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-3.16.0-4-686-pae'
Makefile:216: recipe for target 'modules' failed
make: **** [modules] Error 2

Additional info:
---Core: Intel Atom
---CPU Architecture: i386 (x32/x86)

  • 1
    a) patches needed for the current kernel according to README. b) you have no gcc-4.8 installed. – Ipor Sircer Nov 4 '16 at 22:00
  • Yes I know, I already updated my kernel to 4.0 and there is much less errors, only one that I have installed gcc 4.9 not 4.8 – Enginecrafter77 Nov 4 '16 at 22:58
  • You have to patch the kernel, not just install from a binary package. – Ipor Sircer Nov 4 '16 at 23:00
1

Ok, solved the problem over time myself. The problem was that you need to install kernel 4.1 or higher OR use a patch for older kernel (I have not tried). Then you must install gcc-4.8 to run make.

UPDATE 2018:

Debian stable now includes kernel 4.9, and backports includes 4.16, which is relatively recent, so the problem can be solved quite easily. The RTL8723BS was merged into mainline in 4.12.

UPDATE 2020: The rtl8723bs kernel driver is included in the mainline kernel together with the matching bluetooth drive rtl8723bs-bt. Everything works out-of-the-box in Debian 10 (you may still need to copy the firmware files though).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.