1

I'm trying to compile Lyx 2.2 on my Debian machine from sources. As usual I run ./autogen.sh && ./configure && make, but configuration stops here

configure: error: cannot compile a simple Qt executable. Check you have the right $QTDIR.

So I've installed the qt5-default package, but it didn't solve the problem.

The $QTDIR vairable was empty, so I manually set it to /usr/bin/qmake, and /usr/bin, but none has worked, same error.

Thank you

1

QTDIR shouldn't really be necessary, but try setting it to /usr/share/qt5.

You could build the Debian source package instead:

sudo apt-get install devscripts dpkg-dev build-essential
sudo apt-get build-dep lyx
dget http://httpredir.debian.org/debian/pool/main/l/lyx/lyx_2.2.0-2.dsc
cd lyx-2.2.0
dpkg-buildpackage -us -uc

The first two commands install the packages necessary to build lyx; then dget downloads and extracts the source package, and dpkg-buildpackage builds it and produces a series of .deb packages you can install manually using dpkg as usual.

  • sudo apt-get build-dep lyx This actually worked! – Alex Nov 4 '16 at 14:21
0
./configure QTDIR=/usr/share/qt5 && make

instead of

./configure && make

worked for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.