2

I have recently installed Debian Jessie with KDE on an Asus X556UB, and the audio is not working at all.

I can see and adjust the volume controls with KMix, but it has no effect.

When I tried alsactl init, I got the following message:

No protocol specified
xcb_connection_has_error() returned true
Found hardware: "HDA-Intel" "Intel ID 2809" "HDA:10ec0255,10431c7d,00100002 HDA:80862809,80860101,00100000" "0x1043" "0x1c7d

When I tried to play a WAV file as root with mplayer, I got the following output:

Detected file format: WAV / WAVE (Waveform Audio) (libavformat)
[lavf] stream 0: audio (pcm_u8), -aid 0
Load subtitles in <FOLDER>
Selected audio codec: Uncompressed PCM [pcm]
AUDIO: 22050 Hz, 1 ch, u8, 176.4 kbit/100.00% (ratio: 22050->22050)
No protocol specified
xcb_connection_has_error() returned true
AO: [pulse] Init failed: Access denied
No protocol specified
xcb_connection_has_error() returned true
No protocol specified
xcb_connection_has_error() returned true
[AO_ALSA] alsa-lib: pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Access denied

[AO_ALSA] Playback open error: Connection refused
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
[JACK] cannot open server
[AO SDL] Samplerate: 22050Hz Channels: Mono Format u8
No protocol specified
xcb_connection_has_error() returned true
No protocol specified
xcb_connection_has_error() returned true
[AO_ALSA] alsa-lib: pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Access denied

[AO SDL] Unable to open audio: No available audio device
AO: [null] 22050Hz 1ch u8 (1 bytes per sample)

Could anyone please help me figure out what's wrong?

Thank you in advance.

  • as root run gpasswd -a your_username audio – GAD3R Nov 3 '16 at 14:36
  • Thanks for trying to help, but my user was already in the audio group, and sound doesn't work for root either. – Gabriela Nov 3 '16 at 17:54
  • 1
    try the answer of Stephen Kitt from here: unix.stackexchange.com/a/284147/153195 , run apt-cache search linux-image to find out the right linux-image – GAD3R Nov 3 '16 at 18:01
  • I tried installig it, but I got lots of error messages. – Gabriela Nov 3 '16 at 18:41
  • Tried to install a newer image (4.7), got too many errors... Couldn't even start X. SoI had to reinstall the old one. – Gabriela Nov 3 '16 at 18:52
2

I've fixed it!

What I did was add the following line to /etc/modprobe.d/alsa-base.conf:

options snd-hda-intel model=pch position_fix=1

This was after having installed the firmware-intel-sound package.

But that alone was not enough. I had to run alsamixer and select the Intel sound card (instead of 'default', which didn't work).

Thanks to everyone for your suggestions!

1

As suggested in this thread then you might try adding the following to the bottom of /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=generic

If that file does not exist, just create it and let it contain just that line.

  • I'm afraidthat didn't work.I tried another suggestion on that thread and attempted to install the Realtek HDA driver, but I got the following errorwhile compiling: Rt-Linux-HDaudio-5.18/alsa-driver-RTv5.18/alsa/acore/pcm_native.c:1647:2: error: implicit declaration of function ‘fget_light’ [-Werror=implicit-function-declaration] – Gabriela Nov 4 '16 at 11:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.