My computer froze because of RAM exhaustion. I performed hard reset. When I launched Chromium, I was getting "Aw, Snap!" error on every page. So I deleted the folder .config/chromium/ and ran apt-get purge chromium and then rebooted and installed again. Unfortunately nothing changed. What should I do now?

  • Downgrade to a previous version of chrome. Nov 2, 2016 at 11:16
  • Do you have a lot of open tabs? I find that Chrome maxes out and gives a lot of "Aw, snap" errors around a hundred tabs on my machine, though not everywhere and all the time.
    – tripleee
    Apr 28, 2017 at 14:54
  • What are your Debian and Chromium versions?
    – Paradox
    Apr 5, 2019 at 18:16
  • Debian 7.11, I can't tell the Chromium any more, since I have removed it
    – user965748
    Apr 6, 2019 at 19:20

4 Answers 4


Did you recently have a software upgrade, including the kernel?? I had one a couple of days ago. It was about 160 megs worth of updates. After that I got the "Aw Snap" message in Chromium as well. I uninstalled it, removed the cache and config files, reinstalled it and nothing has changed.

I'm in the same boat.

Part II

I don't think I've ever had RAM exhaustion, so I can't offer an answer for that. My usage is probably a lot different than yours. I run Bleachbit at least once a day to clear out my cache files, etc.

I decided to start over with a fresh install of Wheezy.

I first backed up my home directory on an external HD with the command:

tar -pczf home.tar.gz /home

I then reinstalled Wheezy from the original iso disc I created two years ago.

After it was installed, I checked Chromium and it worked fine. I reset my preferences and continued as usual.

After 24 hours, I got an update notice for 350 megs worth of updates. This was for the kernel plus a bunch of other stuff. Previously, the updates occurred over a longer time period, but now it jumps to the newer stuff. I downloaded and installed them.

After the updates, I discovered that Chromium was getting the "Aw Snap" message again, so I'm assuming that the problem is in the updates somewhere.

My theory is once Wheezy updates past a certain point, Chromium stops working (37.0.2062.120-1). You have to move on to Jessie with a newer version of Chromium to keep using it. Or else find a way to install the Jessie/Chromium version on Wheezy.

Part III

The above answers only apply to the 32 bit Wheezy running on an amd64 machine (long story).

I just updated to the amd64 version of Wheezy on the same machine.

I opened Chromium and got the "Aw Snap" message again right out of the gate; no RAM exhaustion or updates needed.

I figure since I'm running a 64 bit OS now, I can just install Google Chrome and not bother with Chromium. I downloaded and tried to install it with GDebi but got the following message:

Error: Dependency is not satisfiable: libstdc++6(>=4.8.0)

Google only ended support for the 32 bit Wheezy, so why is 64 bit getting this message??

I'll probably ask this as a new question.

Part IV

Here's my question: Can't install Google Chrome on amd64 Wheezy



I'm wondering if you've tried installing chromium from the wheezy backports. Maybe that version works? Put

deb http://ftp.debian.org/debian wheezy-backports main

In your sources.list and then download chromium again. (after purging) You should probably delete your current package lists and comment out your other sources before updating/upgrading, to avoid any conflicts.

What sucks about google chrome is there aren't really error logs unless you enable crash reports and those get sent to google.

What does uname -a say for you? And what version of Chromium are you using? These things are important if you want to file a bug report.

My other suggestion is to just download the tarball [Warning - it's over 2GB] It's probably more recent than your .deb (debian's chromium package)

  • uname -a: Linux michal 3.2.0-4-amd64 #1 SMP Debian 3.2.82-1 x86_64 GNU/Linux and Chromium version is chromium_37.0.2062.120-1~deb7u1_amd64.deb
    – user965748
    Nov 4, 2016 at 0:27
  • Did you try any of my suggestions?
    – trudgemank
    Nov 4, 2016 at 5:56

The next time your system freezes from memory exhaustion, you can try invoking the OOM killer manually before resorting to a hard reset.

1) Add or change kernel.sysrq=1 to /etc/sysctl.conf and run sysctl -p.

2) When the system is out of memory, press Alt+SysRq+f to kill a process.


Chrome uses a lot of RAM while running. To fix this issue, create some swap space on your hard drive by creating a new partition using fdisk/gdisk/parted/whatever then create a swap filesystem on that partition

mkswap /dev/sdX

assuming /dev/sdX is the partition you created. Next, enable the swap space

swapon /dev/sdX

Finally, add a line to /etc/fstab to mount the swap space automatically on boot

/dev/sdX   none   swap   defaults   0 0

Execute the command mount -a to mount the swap space

This partition will hold data that was in memory when there is no memory left. It is like extending RAM but with slower access.

Not the answer you're looking for? Browse other questions tagged or ask your own question.