2

I try to install from source GCC 6.2.0 with checkinstall but it fails.

I run configure and make, all seems fine, but when I try checkinstall I have this error:

ranlib: could not create temporary file whilst writing archive: No more archived files

Log when it occurs:

make[4]: Leaving directory '/home/alexandre/Documents/objdir/libcc1'
make[3]: Leaving directory '/home/alexandre/Documents/objdir/libcc1'
make[2]: Leaving directory '/home/alexandre/Documents/objdir/libcc1'
make[2]: Entering directory '/home/alexandre/Documents/objdir/x86_64-pc-linux-gnu/libgcc'
/bin/bash /home/alexandre/Documents/objdir/../gcc-6.2.0/libgcc/../mkinstalldirs /home/alexandre/gcc-6.2.0/lib/gcc/x86_64-pc-linux-gnu/6.2.0
/usr/bin/install -c -m 644 libgcc_eh.a /home/alexandre/gcc-6.2.0/lib/gcc/x86_64-pc-linux-gnu/6.2.0/
chmod 644 /home/alexandre/gcc-6.2.0/lib/gcc/x86_64-pc-linux-gnu/6.2.0/libgcc_eh.a
ranlib /home/alexandre/gcc-6.2.0/lib/gcc/x86_64-pc-linux-gnu/6.2.0/libgcc_eh.a
ranlib: could not create temporary file whilst writing archive: No more archived files
Makefile:1112: recipe for target 'install-shared' failed
make[2]: *** [install-shared] Error 1
make[2]: Leaving directory '/home/alexandre/Documents/objdir/x86_64-pc-linux-gnu/libgcc'
Makefile:17621: recipe for target 'install-target-libgcc' failed
make[1]: *** [install-target-libgcc] Error 2
make[1]: Leaving directory '/home/alexandre/Documents/objdir'
Makefile:2323: recipe for target 'install' failed
make: *** [install] Error 2

****  Installation failed. Aborting package creation.

Thanks in advance.

1

This is a known issue. Sometimes checkinstall breaks an installation because of missing folder. It also (for some bug) refuses to create a new folder though it has necessary permission to create that. All you need to do in this case is to create the folder manually. In this case create the folder /home/alexandre/gcc-6.2.0/lib/gcc/x86_64-pc-linux-gnu/6.2.0 and set permission manually.

sudo mkdir /home/alexandre/gcc-6.2.0/lib/gcc/x86_64-pc-linux-gnu/6.2.0

sudo chmod 644 /home/alexandre/gcc-6.2.0/lib/gcc/x86_64-pc-linux-gnu/6.2.0

Another possibility is that you may have missed the configuration step before installing it. Please try configuring with

./configure --disable-static

, recompiling it and installing it with checkinstall.

  • Now its makedir not working... codemkdir: cannot create directory /home/alexandre/gcc-6.2.0/libexec/': No such file or directorycode` I reconfigure, remake and sudo mkdir / chmod. – ThisIs Random Nov 1 '16 at 17:10
  • Possibly there is no such folder called gcc-6.2.0 in /home/alexandre directory. You need to start creating folder from /home/alexandre and all the rest of the folders in next subsequent steps. – trishnendu Nov 1 '16 at 17:23
  • This is what I did, the problem occurs when I run checkinstall. – ThisIs Random Nov 1 '16 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.