1

Can someone shed a light on my situation? I have a Debian Jessie system, running XFCE Desktop. When I plug in an external USB harddisk (a Seagate Backup Plus Slim 2TB to be exact), then mount it via GUI (I use Thunar and click on the drive icon), it will first be mounted on /media/usb0. And it is very very slow (copying files is at ~80KB/s).

If I unmount this drive (e.g. via Thunar again by right clicking the drive icon and selecting Unmount from the menu, or via CLI by typing "umount /media/usb0"), then mount again without re-plugging the drive, it will now be mounted at /media/NAME (where NAME is the ext3 filesystem label) and the data transfer speed is normal this time.

This starts happening a few months ago but now is always like this. I have to mount, unmount, remount to make the drive usable.

This also happens with other external USB drives that I try.

Any idea why this happens?

More diagnostics data as follows.

journalctl output after plugging:

Nov 01 23:18:21 MACHINENAME kernel: sd 21:0:0:0: [sdc] Spinning up disk...
Nov 01 23:18:24 MACHINENAME kernel: ...ready
Nov 01 23:18:24 MACHINENAME kernel: sd 21:0:0:0: [sdc] 3907029167 512-byte logical blocks: (2.00 TB/1.81 TiB)
Nov 01 23:18:24 MACHINENAME kernel: sd 21:0:0:0: [sdc] Write Protect is off
Nov 01 23:18:24 MACHINENAME kernel: sd 21:0:0:0: [sdc] Mode Sense: 4f 00 00 00
Nov 01 23:18:24 MACHINENAME kernel: sd 21:0:0:0: [sdc] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Nov 01 23:18:24 MACHINENAME kernel:  sdc: sdc1
Nov 01 23:18:24 MACHINENAME kernel: sd 21:0:0:0: [sdc] Attached SCSI disk
Nov 01 23:18:24 MACHINENAME usbmount[15500]: /dev/sdc does not contain a filesystem or disklabel
Nov 01 23:18:25 MACHINENAME usbmount[15532]: executing command: mount -text3 -osync,noexec,nodev,noatime,nodiratime /dev/sdc1 /media/usb0
Nov 01 23:18:25 MACHINENAME kernel: EXT4-fs (sdc1): mounting ext3 file system using the ext4 subsystem
Nov 01 23:18:25 MACHINENAME kernel: EXT4-fs (sdc1): warning: mounting fs with errors, running e2fsck is recommended
Nov 01 23:18:25 MACHINENAME kernel: EXT4-fs (sdc1): mounted filesystem with ordered data mode. Opts: (null)
Nov 01 23:18:25 MACHINENAME usbmount[15547]: executing command: run-parts /etc/usbmount/mount.d
Nov 01 23:18:25 MACHINENAME org.gtk.Private.UDisks2VolumeMonitor[11556]: index_parse.c:191: indx_parse(): error opening /media/usb0/BDMV/index.bdmv
Nov 01 23:18:25 MACHINENAME org.gtk.Private.UDisks2VolumeMonitor[11556]: index_parse.c:191: indx_parse(): error opening /media/usb0/BDMV/BACKUP/index.bdmv

mount output after mounting:

/dev/sdc1 on /media/usb0 type ext3 (rw,nodev,noexec,noatime,nodiratime,sync,data=ordered)

journalctl output after unmounting:

Nov 01 23:23:16 MACHINENAME udisksd[11673]: Unmounted /dev/sdc1 on behalf of uid 1000

journalctl output after remounting:

Nov 01 23:23:58 MACHINENAME kernel: EXT4-fs (sdc1): mounting ext3 file system using the ext4 subsystem
Nov 01 23:23:58 MACHINENAME kernel: EXT4-fs (sdc1): warning: mounting fs with errors, running e2fsck is recommended
Nov 01 23:23:58 MACHINENAME udisksd[11673]: Mounted /dev/sdc1 at /media/seagate3 on behalf of uid 1000
Nov 01 23:23:58 MACHINENAME org.gtk.Private.UDisks2VolumeMonitor[11556]: index_parse.c:191: indx_parse(): error opening /media/seagate3/BDMV/index.bdmv
Nov 01 23:23:58 MACHINENAME org.gtk.Private.UDisks2VolumeMonitor[11556]: index_parse.c:191: indx_parse(): error opening /media/seagate3/BDMV/BACKUP/index.bdmv
Nov 01 23:23:58 MACHINENAME kernel: EXT4-fs (sdc1): mounted filesystem with ordered data mode. Opts: (null)

mount output after remounting:

/dev/sdc1 on /media/seagate3 type ext3 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)
  • A bit of diagnostic info would be nice: Output of mount in both states, messages in syslog directly after mount in both states. – dirkt Nov 1 '16 at 11:56
  • @dirkt: Added to article. – Gerry Lufwansa Nov 1 '16 at 16:26
  • The filesystem has errors. First thing I'd try is to unmount it (from commandline), and run fsck /dev/sdc1 on it (as root). See if that fixes the problem. – dirkt Nov 1 '16 at 17:46
  • 1
    usbmount mounts with option sync (for whatever reason, maybe they want to enable you to unplug it without doing to much damage when it's not unmounted), while the remount doesn't use that option. Try to configure usbmount to mount it without that option. On my system, configuration is in /etc/usbmount/usbmount.conf. – dirkt Nov 1 '16 at 19:55
  • 2
    You should probably uninstall the package providing usbmount as it conflicts with what your desktop is doing for you, and you shouldn't need both (unless you want automounting of any usb key when no one is logged in, which is probably not a good idea). – meuh Nov 3 '16 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.