0

I've just applied recent updates (152 like two days ago and about 40 today) and the symptoms persist: from any application printing (e.g. Ctrl+P) can only print into a file despite my default printer (I use only one, at work) being correctly installed — I printed a test page while installing it; anywhere else no hardware printer listed.

When I open any document and try to print it using keyboard shortcuts or the File > Print menu, I only have "Print to a file". However when I run the printer administration program (translated from French: «Printer Configuration») I can see my printer's there.

What's going on? How can I fix this?

BTW: I'm also trying to update the PPD file for the printer from that very printer manager and I get an authentication prompt — it needs a user name and a password, obviously not mine as they don't seem to work. So I'd also like to know what to do so that my user name and password are accepted for those changes.

CUPS is not my favourite... cup of tea. It always worked right out the box. So far. So I need some guidance.

0

I had the same problem. They split out the printer support for gtk+ 3.x applications into a separate package, which you have to install manually.

Just install the gtk3-print-backends package and you should be good to go:

sudo pacman -S gtk3-print-backends
1
  • Thanks a lot ! I just figured it out right after browsing Manjaro forums. It solved my issue. – user86969 Nov 4 '16 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy