2

I'm using a Chromebook and would like to navigate inside the Android container via the shell. The container is mounted at the path /run/containers/android_XXXXX. When trying to cd into the directory, I'm told Permission Denied. I've tried running the command as sudo, but for some reason the cd command becomes inaccessible. I've ran chmod u+x on the directory, but no dice.

What steps can I take from here?

I've ran stat on the directory, which returns the following:

  File: ‘android_XXXXXX/’
  Size: 80              Blocks: 0          IO Block: 4096   directory
Device: fh/15d  Inode: 59640       Links: 3
Access: (0700/drwx------)  Uid: (655360/ UNKNOWN)   Gid: (655360/ UNKNOWN)
Context: u:object_r:tmpfs:s0
Access: 2016-10-31 04:04:52.680000040 +0000
Modify: 2016-10-31 04:04:52.200000040 +0000
Change: 2016-10-31 04:44:54.990001186 +0000
 Birth: -
  • Since you're talking about a permission problem, where is your whoami and the permission listing for the directory in question? – Julie Pelletier Oct 31 '16 at 5:01
4

The directory is drwx------ so only someone whose uid is 655350 (which is not listed in the password file) can read it or enter it.

sudo cd not being able to find the cd command is expected, it is a builtin to the shell. If it wasn't builtin then it wouldn't work. Say your current shell has a process ID of 54000, you ran the /bin/cd command, it might be PID 54309. It would change the directory for process 54309, and then exit. process 54000 would still be in its original directory.

chmod u+x alters user (owner) permission.

What you want is sudo chmod go+rx /run/containers/android_XXXXX

  • Worked like a charm, thank you. I haven't ever seen the 'go' parameter before. Thanks for clarifying the behaviour of PIDs in the shell. – Mapsy Oct 31 '16 at 10:44
  • 1
    g is group and o is other, I was just changing them both at the same time. Almost certainly I could have used o+rx – icarus Oct 31 '16 at 10:54
  • Ah, I've got you. That's certainly useful to know! – Mapsy Oct 31 '16 at 10:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.