0

I am trying to configure a network PXE boot server on my local network. I am currently following the Centos7 guide at http://www.tecmint.com/install-pxe-network-boot-server-in-centos-7. One of the required network services is DHCP. My ISP is AT&T Uverse and the router's model is 5268ACFXN. The router already has DHCP configured. Will there be an issue if my configuration file points to my router for the DHCP services, or will I have to setup my own local DHCP server, and disable the DHCP service on my router.

0

Yes you need setup your own local DHCP server and disable the DHCP service on your router. Use ISC dhcp server for it.

Don't forget add dhcp options default rote and DNS name server. They must be your router internal ip address.

0

You have indeed to disable the DHCP/DNS services of your ISP modem/router.

For the TFTP service to work some configuration/fields have to be supported by the DHCP services, that your ISP equipment won't let you configure ; namely the attributes:

  • next-server that tells the client in the DHCP answer from which TFTP server it will have to download the files;
  • filename in the lease that will tell per machine/MAC which files to download.

Whilst more challenging, it might also be more educative, and more useful for bigger infra-structures to setup BIND+ISC DHCP+tftpboot for this service.

From the Debian manuals:

4.5. Preparing Files for TFTP Net Booting

group {
  next-server 192.168.1.3;
  host tftpclient {
# tftp client hardware address
  hardware ethernet  00:10:DC:27:6C:15;
  filename "pxelinux.0";
 }
 }

setting up BOOTP with ISC dhcpd is really easy, because it treats BOOTP clients as a moderately special case of DHCP clients. Some architectures require a complex configuration for booting clients via BOOTP. If yours is one of those, read the section Section 4.5.2, “Setting up a DHCP server”. In that case, you will probably be able to get away with simply adding the allow bootp directive to the configuration block for the subnet containing the client, and restart dhcpd with /etc/init.d/dhcpd3-server restart.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.