Mathxl is a (expensive) platform I need to use for homework but I can't get it to work. (It's a white screen) The stated system requirements include

Linux   Ubuntu  Firefox 46.0 to latest

Which should cover my Debian Firefox ESR. The software requirements are:

Adobe® Reader®
Wolfram® CDF Player
Adobe® Flash® Player
Java™ Runtime Environment
Third Party Cookie Check

Three are working (Flash w/ freshwrapper for pepperflash, java w/ iced tea, and cookies). Adobe Reader and Wolfram CDF aren't functional and I don't believe they need to be for me to do my homework. I can view PDFs without Adobe Reader and the description of Wolfram CDF "Allows you to view and explore the Interactive Figures and e-text of certain titles that were created using Mathematica®" makes me think it's not commonly used. Compare to Flash "Allows you to view the questions within the course. You won't be able to complete any questions if you don't install this component!". But I can't complete any questions. I've been trying to figure this out for hours but I must defer to the powers that be on SE because I have to get this homework done. I'll post from the source of the applet if necessary.

My specs:

Linux debian 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u2 (2016-10-19) x86_64 GNU/Linux
  • Is it illegal or unethical to bump this? It's really important.
    – trudgemank
    Oct 31, 2016 at 1:41
  • 2
    It's not illegal or unethical, but since this seems like a problem with a proprietary software product your probably going to get a better answer by just contacting the vendor directly. Alternatively, set up Ubuntu in a VM or something and at least verify that things work with the supported software environment.
    – larsks
    Oct 31, 2016 at 2:18
  • Someone on ubuntu had this issue too but it was never addressed ubuntuforums.org/showthread.php?t=2323844 so this isn't just a deb issue. Thanks for responding!
    – trudgemank
    Oct 31, 2016 at 2:50
  • Hey @trudgemank! I'm glad you were able to resolve your issue, please consider putting your update as an answer and self-accepting it so future visitors can more easily see how you resolved your problem!
    – Sam Holmes
    Oct 31, 2016 at 7:28
  • False celebration. It didn't work. I was overexcited by an initialization screen I hadn't seen before. Sigh. :(
    – trudgemank
    Oct 31, 2016 at 7:30

1 Answer 1


I contacted tech support and they asked me if I tried it on chrome. I hadn't and Chromium worked for whatever reason. I wish I knew why. So yeah, install Chromium if you have this problem.

  • This is a common problem for Ubuntu, Debian, and other *nix platforms. If a webpage only returns a blank white screen, try Chromium (and make sure pepperflash is installed) or Google Chrome. Newer versions of flash and Firefox are now designed to allow DRM content so this may not be an issue in the future; although, I have yet to see this correct any past issues.
    – mchid
    Aug 7, 2017 at 22:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.