3

I am trying to run tflearn (debian 8)

When I run that code locally , it runs fine (its shows the windows). But when I do ssh , I get errors. Note that I am able to open other gui applications over ssh (like xfce4)

This is the snippet of the error. Note the first two lines

libGL error: No matching fbConfigs or visuals found libGL error: failed to load driver: swrast

Traceback (most recent call last):   File "test.py", line 453, in
<module>
    tf.app.run()   File "/usr/local/lib/python3.4/dist-packages/tensorflow/python/platform/app.py",
line 30, in run
    sys.exit(main(sys.argv))   File "test.py", line 450, in main
    train(session, graph_ops, num_actions, saver)   File "test.py", line 399, in train
    env.render()   File "/usr/local/lib/python3.4/dist-packages/gym/core.py", line 192, in
render
    return self._render(mode=mode, close=close)   File "/usr/local/lib/python3.4/dist-packages/gym/envs/atari/atari_env.py",
line 119, in _render
    from gym.envs.classic_control import rendering   File "/usr/local/lib/python3.4/dist-packages/gym/envs/classic_control/rendering.py",
line 23, in <module>

I don't have a graphics card installed, and Im using an amd processor on the GA-78LMT-USB3

  • xfce4 is using x11 protocol, which can be tunneled over ssh. Opengl can't be tunneled via x11. – Ipor Sircer Oct 30 '16 at 17:30
  • so does that mean there is no way to do what I want ? – harveyslash Oct 30 '16 at 17:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.